Need some emergency help! VoIP line periodically goes down!



  • Recently, I switched my Company over to Nextiva to host our SIP trunk. I went through the porting process etc.

    My Asterisk box will connect to their server and register just fine. I can call out, calls come in, etc. …for a few hours.

    After a period of time, the connection says its established, but the registration status goes to "offline".
    If I look at the control panel, from their end it says I'm connected.

    The only way to bring the whole system back online, and have a connection & registration is to reboot PFsense. After that, it will work for a few more hours.

    I have not dug too deep, I am nearing the end of my day and need to have this fixed ASAP so calls can continue to come in. The only thing I have done so far is searched the firewall logs for the IP of the SIP server I am registering with. Nothing came up.

    thank you!



  • I hate to double post, but I really am desperate here..
    I came across these two resources, but don't fully understand them..

    1. http://sipxecs.blogspot.com/2009/08/sip-trunking-gotcha-with-pfsense.html
    2. http://doc.pfsense.org/index.php/Static_Port

    If anyone who understands what is going on here can elaborate on the above help documents, I'd greatly appreciate it.


  • Netgate Administrator

    SIP problem due to re-writing the source ports would show up imediately, you would just see errors not successful calls then errors.

    Your description sounds more like the machine is running out of resources of some type. Too many conncetions? MBUF problems?

    Are there any errors in the system logs?
    From the command line try 'netstat -m' and paste the result here. Does it differ after call start to fail?

    What hardware are you running?

    I am by no means an SIP expert though.  ::)

    Steve



  • Not enough info here to attempt even a preliminary diagnosis…

    Has your existing setup (asterisk server + pfsense) worked correctly in the past, i.e. with a previous SIP provider and the problems only started when you moved your SIP trunk to Nextiva ? Do you have multiple WANs?

    You'd need to provide info about pfsense and asterisk versions, and what each of them thinks it's happening (i.e. pfsense's NAT states and asterisk's CLI show peers etc)

    PS: If you're in a hurry consider posting in the Bounty sub-forum.



  • Did you tried to just reset states instead of pfSense reboot?


Locked