2.1 wireless RUN0 (RT3070) driver with Iphone + SMB



  • I just thought I'd write up a little story that I can't seem to find any forum posts relating to.

    I have set up a realtek USB RT3070 in a HP microserver (mounted internally) in AP mode, which worked fine. Set to WPA2, 802.11g mode. Very neat all in one router in this setup). WIFI is bridged to LAN.

    1st thing I noticed after allowing DHCP (UDP port 67/68) and IPv4/TCP as a firewall rule between the bridge, is that no matter what "Pass" firewall rules I set up, is that browsing worked perfectly on a windows 7 laptop, but as soon as I tried browsing the network (SMB - windows to windows), or browsing on one of two iphones, things started getting very sporadic. Would work for a few seconds, then drop off. Also, the wireless card would crap out entirely (as in the light would go off until unplug/replug).

    I started logging firewall rules, and noticed it was blocking basically one IPv6 packet for every IPv4. I have no need for IPv6, so thought it wasn't an issue. On iphone, speedtest would run anywhere between 10kb/s and 6.8Mb/s depending on what it felt like, and connecting to app store etc was impossible unless I switched over to 3G/LTE.

    Added a rule to allow IPv6 just to see what would happen and instantly everything started working perfectly. I've noticed people talking about slowness on IOS6 randomly, and solutions are things like "change router". I'm wondering if the way those routers that people are having issues with is the ability to traverse IPv6?

    Still can't work out if this is hardware of software, but hopefully anyone with similar issues will find this.

    Just wanted to see if anyone had had similar issues, or if this is something everyone but me already knew ?? :D


Locked