Unable to communicate with www.pfsense.com -> when accessing available packages



  • Any time I attempt to search available packages, I get this error
    "Unable to communicate with www.pfsense.com. Please verify DNS and interface configuration, and that pfSense has functional Internet connectivity."

    DNS is pointed to 8.8.8.8 8.8.4.4, no DNS forwarding, and I can resolve hostnames from the command line.

    if I try accessing packages manually from the command line
    fetch -o - http://www.pfsense.org/packages/pkg_config.8.xml

    I get this error.

    fetch: http://www.pfsense.org/packages/pkg_config.8.xml: No buffer space available

    This is directly connected to the internet, no proxy no other filter/firewall.
    I had previously installed a package, so it worked at one time.
    Please advise - Thanks



  • Do you have free space on disk? I've never seen buffer error on fetch cmd.



  • I'm good on space.  I might lab up another one with the same config, and see if I have similar problems.  This machine is remote and very busy, so I'm hoping I don't have to do that.  Storage is on a 1G CF

    [2.0.1-RELEASE][root@pfsense.xxxxx]/root(1): df -kh
    Filesystem          Size    Used  Avail Capacity  Mounted on
    /dev/ufs/pfsense0    443M    215M    193M    53%    /
    devfs                1.0K    1.0K      0B  100%    /dev
    /dev/md0              38M    690K    35M    2%    /tmp
    /dev/md1              58M    10M    43M    19%    /var
    /dev/ufs/cf          49M    552K    45M    1%    /cf
    devfs                1.0K    1.0K      0B  100%    /var/dhcpd/dev
    [2.0.1-RELEASE][root@pfsense.xxxx]/root(2):



  • @atheos:

    Storage is on a 1G CF

    you have to mount it rw before any package install, did you did that?

    /etc/rc.conf_mount_rw

    and

    /etc/rc.conf_mount_ro



  • still no love

    [2.0.1-RELEASE][root@pfsense.xxxx]/root(4): cd /
    [2.0.1-RELEASE][root@pfsense.xxxx]/(5): /etc/rc.conf_mount_rw
    [2.0.1-RELEASE][root@pfsense.xxxx]/(6): fetch -o - http://www.pfsense.org/packages/pkg_config.8.xml
    fetch: http://www.pfsense.org/packages/pkg_config.8.xml: No buffer space available
    [2.0.1-RELEASE][root@pfsense.xxxx]/(7): /etc/rc.conf_mount_ro


  • Netgate Administrator

    Can you fetch to /tmp ?

    Steve



  • cannot fetch to /tmp, but I can create a file in there.


  • Netgate Administrator

    Ah so perhaps a network buffer problem, though I would expect some other network issues.
    What does 'netstat -m' show?

    Steve



  • 1187/5608/6795 mbufs in use (current/cache/total)
    1181/5353/6534/25600 mbuf clusters in use (current/cache/total/max)
    1180/5348 mbuf+clusters out of packet secondary zone in use (current/cache)
    0/44/44/12800 4k (page size) jumbo clusters in use (current/cache/total/max)
    0/0/0/6400 9k jumbo clusters in use (current/cache/total/max)
    0/0/0/3200 16k jumbo clusters in use (current/cache/total/max)
    2660K/12284K/14944K bytes allocated to network (current/cache/total)
    0/0/0 requests for mbufs denied (mbufs/clusters/mbuf+clusters)
    0/0/0 requests for jumbo clusters denied (4k/9k/16k)
    0/4/6656 sfbufs in use (current/peak/max)
    0 requests for sfbufs denied
    0 requests for sfbufs delayed
    0 requests for I/O initiated by sendfile
    0 calls to protocol drain routines

    anything interesting in there?  possibly related, download speeds are great, upload speeds are the opposite of great.


  • Netgate Administrator

    I would say that for some reason your tcp transmit buffer is full. Or at least it's emptying far slower than it should.
    Just a guess though.

    If you Google the problem you'll see it can be caused by something as simple as a loose network card or bad cable.

    Steve


Locked