Squidguard not applying rules



  • After reinstalling both packages up to 3 times before both services would run after a reboot, I am still having issues with squidguard.
    I pretty much followed following guide after my failed first try : http://www.howtoforge.com/pfsense-squid-squidguard-traffic-shaping-tutorial



    And under the general squid options I have the following under custom options :
    redirect_program /usr/local/bin/squidGuard -c /usr/local/etc/squidGuard/squidGuard.conf;redirector_bypass off;url_rewrite_children 5

    What am I trying to accomplish?

    • during work hours 07:00 till 18:59
    • sites as facebook and less wanted sites are to be blocked
    • the proxy has to be transparent, no additional configuration is possible on all clients connects on the same subnet as LAN range

    could anyone give me some pointers what could be wrong?
    I applied changes multiple times under squidguard options and reboot the system twice.



  • Did you select an Option for the "Target rules" ? Allow, deny, whitelist, –- ?

    Further, when running squid in transparent mode then you cannot block httpS websites with squid, squidguard because squid is only filtering port 80, http.
    Try with one simple site to make sure that blocking websites is working in general.



  • Solved the problem by reinstalling squid for a fourth time and setting the allowed subnets again under Acces Control Tab.
    After restarting the system everything worked fine.

    Blocked Facebook by using an alias with all facebook servers combined with a firewall rule that drops all connections to the alias (and from).

    Thanks for the help.


Locked