Multi WAN and same gateway IP address



  • Hi,

    I am using pfsense 2.0-BETA4 with two WANs from the same ISP. Pfsense is connecting with PPPoE modems. Until recently, the ISP provided two separate gateways IP addresses. But, now the same gateway is set for each WAN interface. The consequence is that only one WAN is working. I have read one of the device must be then behind a NAT for using both WANs. Is it possible with pfSense 2.1 to use two WANs with the gateway IP address ?

    Thanks. Regards.

    Éric.


  • Rebel Alliance Developer Netgate

    It is possible even on 2.0.1, which is the most current stable release (and the one you should be using) since PPPoE is a special case where multiple gateways aren't necessarily a fatal condition.



  • I have the same problem. How is the solution?


  • Rebel Alliance Developer Netgate

    There is no special solution. If you're on a current release, it just works for PPPoE without needing anything special.

    It doesn't work for other types (static, dhcp, etc).



  • @jimp:

    It is possible even on 2.0.1, which is the most current stable release (and the one you should be using) since PPPoE is a special case where multiple gateways aren't necessarily a fatal condition.

    I upgraded to 2.0.1 release and it is working now. The two WAN are up together.
    Thanks for the help !

    Éric



  • Hi again,

    I have an issue with my multiwan configuration.
    I am using 2 WAN :
    -> WAN an ADSL line with 2Mb/s bandwith
    -> WAN2 another ADSL line from the same ISP with 900 Kb/s bandwith

    In "System" > "Routing" > "Gateways", I have created "WAN" as default with weight 3 and "WAN2" with weight 1.
    In "Groups", I have created 3 groups :

    • BalanceWAN1WAN3 with WAN and WAN2 both in Tier 1
    • WAN1FailOverWAN2 with WAN in Tier 1 and WAN2 in Tier 2
    • WAN2FailOverWAN1 with WAN in Tier 2 and WAN2 Tier 1

    My problem is that WAN2 line is mainly used instead of WAN1. I would like traffic to go through WAN first.

    I have also created a "Traffic Shaper" configuration with "Single Lan multi Wan". I have 3 queues :

    • qAck
    • qDefault
    • qVoIP
      I would VoIP going first to WAN2 and other traffic to go to WAN.

    How can I configure to do that ?

    Thanks.

    Éric




  • I finally read http://forum.pfsense.org/index.php/topic,43475.msg231624.html#msg231624
    I have checked "Disable Gateway Monitoring" in WAN2 "Gateway" configuration. Now, the traffic is going into WAN. I have to find another IP to monitor inside my ISP network.

    Éric



  • Hi,

    I could not make IP monitoring working. When pppoe0 and pppoe1 are up, I can monitor an internal ISP IP from pppoe0 but not from pppoe1. I have disconnected pppoe1 for more tests and I could not ping DNS server and even www.google.com. I do not see any DNS server in Dashboard. DNS server were added from pppoe0. Routing table change to pppoe1 interface when I disconnected pppoe0. If I reconnect pppoe0, DNS servers IP are back with new ones that are added. Routing table is not reversed back to pppoe0.

    I have to disable IP monitor on pppoe1. If I set an ISP internal IP address, pppoe1 est set as offline. Maybe, my internal IP is false, but I cannot check it… And any idea ? Thanks in advance.

    Éric



  • set pingable public ip's as monitor address for example google's dns servers 8.8.8.8 or 8.8.4.4



  • @heper:

    set pingable public ip's as monitor address for example google's dns servers 8.8.8.8 or 8.8.4.4

    Thanks ! It worked. I cannot ping from "Diagnostics :Ping" page internal ISP addresses (that I got with a traceroute command). I can ping only gateway IP address for both WAN and WAN2 interfaces.

    Eric


Locked