[solved] version 1.2.3 Slow Wan (no autosense)



  • Hello,

    Our customer have a 50/50 MB connection. But we can test max 20/20 with speedtest.
    If we connect a pc directly to the modem it is okay.

    The provider says the lan of the modem is half duplex if we connect the pfSense tot the modem.

    - <interfaces>- <lan><if>vr0</if> 
    <ipaddr>*.*.*.*</ipaddr> <subnet>24</subnet> <media><mediaopt><bandwidth>100</bandwidth> 
    <bandwidthtype>Mb</bandwidthtype></mediaopt></media></lan> - <wan><if>vr1</if> <mtu><media>100baseTX</media> 
    
    <mediaopt>full-duplex</mediaopt> <bandwidth>100</bandwidth> <bandwidthtype>Mb</bandwidthtype> <spoofmac><ipaddr>*.*.*.*</ipaddr> <subnet>29</subnet> <gateway>*.*.*.*</gateway></spoofmac></mtu></wan></interfaces> 
    

    How can we solve this problem?


  • Netgate Administrator

    If you have a duplex mismatch then you will never see good throughput.
    Ideally both ends should be set to 'auto'. If the modem is fixed then you must replicate that setting in pfSense.
    Are you really saying the modem is fixed at half duplex? That seems very unlikely.  :-\

    Any reason you are still running 1.2.3?

    Steve



  • @stephenw10:

    If you have a duplex mismatch then you will never see good throughput.
    Ideally both ends should be set to 'auto'. If the modem is fixed then you must replicate that setting in pfSense.
    Are you really saying the modem is fixed at half duplex? That seems very unlikely.  :-\

    Any reason you are still running 1.2.3?

    Steve

    Thankyou for your answer.
    Modem is set to autosensing, and if we hangs A pfsense on the lan, they see that it running on half duplex.
    Can I set PFSense tot autosensing?
    How can I do that? which config line must I use?


  • Netgate Administrator

    There's a setting for it in the webGUI in: Interfaces: YourInterface: (advanced) speed and duplex.
    However you won't see that if your WAN is PPP. To set that you need to add the physical NIC as an interface with type 'none' and set it there instead. That is much mode difficult in 1.2.3 though.
    By default the pfSense NICs will be se to either auto or default anyway.
    Has this problem just started? I would look for a possible cable or NIC fault.
    Anything relevant in the system log?

    Steve



  • @stephenw10:

    There's a setting for it in the webGUI in: Interfaces: YourInterface: (advanced) speed and duplex.
    However you won't see that if your WAN is PPP. To set that you need to add the physical NIC as an interface with type 'none' and set it there instead. That is much mode difficult in 1.2.3 though.
    By default the pfSense NICs will be se to either auto or default anyway.
    Has this problem just started? I would look for a possible cable or NIC fault.
    Anything relevant in the system log?

    Steve

    Hi Steve,

    I cannot find advanced option in de GUI on interface Wan.
    Customer has a new internet connection which must be more faster..

    The ip is set on static. No PPP.


  • Netgate Administrator

    Hmm, could be that 1.2.3 doesn't have it. It's been a while since I used it (2.0 was released over a year ago but was in general use for a long time before that).
    I assume the code segment in your first post is from the config.xml file?

    You can modify the config file manually and restore it. Keep a copy of the unmodified file to restore if it all goes wrong!

    The interfaces wan section of the file is currently:

    
     <wan><if>vr1</if>
     <mtu><media>100baseTX</media> 
    <mediaopt>full-duplex</mediaopt>
    <bandwidth>100</bandwidth>
    <bandwidthtype>Mb</bandwidthtype>
     <spoofmac><ipaddr>*.*.*.*</ipaddr> 
    <subnet>29</subnet>
    <gateway>*.*.*.*</gateway></spoofmac></mtu></wan> 
    

    You can see it has a manually assigned speed and duplex, 100Mbps Full duplex. When the modem tries to autonegotiate a speed and duplex it will fail, because the pfSense interface is not negotiating, and fall back to half duplex. You need to set the pfSense interface back to defaults. Remove the options from your config file like this:

    
     <wan><if>vr1</if>
     <mtu><media><mediaopt><bandwidth>100</bandwidth>
    <bandwidthtype>Mb</bandwidthtype>
     <spoofmac><ipaddr>*.*.*.*</ipaddr> 
    <subnet>29</subnet>
    <gateway>*.*.*.*</gateway></spoofmac></mediaopt></media></mtu></wan> 
    

    Doing this carries some risk, if you edit the file incorrectly it won't load at boot properly. You can always restore the old file.
    Are you sure there is no option to do this in the webgui?

    Steve



  • The problem is solved by the provider. They have set the LAN interface on 100 / Full duplex.


Locked