SuperMicro D525 - Installing Error cannot boot



  • Trying to install pfsense on 1U SuperMicro d525 and I'm getting

    "Stopped at  0xc56c: ***error reading from address c56c"

    I thought it was a bad cd so I tried another with same results.

    I also see

    Fatal trap 9: general protection fault while in kernel mode
    cpuid=0; apic id = 00

    any help would be appreciated



  • Anyone have issues installing pfsense to a SuperMicro D525?

    I read on the pf forum that many have pfsense installed on this same hardware.


  • Netgate Administrator



  • I have one, lots and lots of others do too.

    @stephenw10:

    Bad ram?

    That'd be my guess.



  • sorry for the late response. I had to step away from this project for a while. I changed the ram and still no go. I have added the imagebin image of my screen. hopefully someone can help me come up with a workaround.

    http://imagebin.org/240144



  • What version of pfSense? (Old operating systems don't always work on "new" hardware.)

    What is displayed when you type "bt" then tap the Enter key? (bt should display a stack trace.)

    Have you run a memory diagnostic program such as Memtest86+ on that hardware and memory? It is possible (but unlikely) you tried two bad memory sticks. It is possible (but unlikely) there is a manufacturing defect on your motherboard leading to problems on certain memory accesses.
    If Memtest86+ completes a least a couple of passes reporting zero errors you can be highly confident the combination is good.



  • Im running Pfsense 2.0.1. Should I be running maybe the i386 version?

    Ran the mem test a few times and all clean.

    Stumped

    Been reading and others have disbaled HT and ACPI and some havent. Whats is the normal failsafe settings, to disable or to enable?



  • Did 2 installations today with X7SPE-HF-D525.  Went as planned.  Any chance you are using a USB CD/DVD drive?  Be sure to select USB installation at the menu.



  • I've only used i386 on those. It's possible that's some kind of hardware-specific driver issue that only exhibits itself on 64 bit. I'd try i386. I don't think those support > 4 GB RAM anyway IIRC so it doesn't matter which you use.

    @Its:

    Any chance you are using a USB CD/DVD drive?  Be sure to select USB installation at the menu.

    That would result in a mountroot failure rather than a kernel panic so I don't think that's the cause.



  • Just Installed pfsense 2.0.2 without a hitch. I think next time I will go with an i7 setup.

    Thank you guys for the help.


Locked