Empty Acknowledge Messages, Banwidthd not working, status services broken, ipv6

  • Hi all,

    just upgraded from 2.0.1 to 2.1 from http://snapshots.pfsense.org/FreeBSD_RELENG_8_3/i386/pfSense_HEAD/.updaters

    Now i sometimes get empty messages where usually was a message running and a link "acknowledge all". The text is not visible in chrome and safari.

    Bandwidthd is running but doesnt graph anything. The bandwidthd page justs shows "Please start bandwidthd to populate this directory." but it was running fine with 2.0.1, also tried to restart etc. doesnt work too, just stays empty.

    Also the Page "Status: Services" shows bandwidth running, and then a php error :

    Fatal error: Call to undefined function get_shortcut_by_service_name() in /usr/local/www/status_services.php on line 262

    On another sidenote i do not see the loadbalancer listenning for IPV6 :( i can add ipv6 virtual ips but the daemon is just not listenning. netstat only shows the ports configured in the loadbalancer virtual servers for tcp4.

    In addition i have 14 ipv4 carp vips. That worked fine with all syncing between my 2 pfsense nodes before. Now as soon as i add a ipv6 carp virtual ip carp goes absolutly crazy, switching IPv4 carp vips from backup to master every minute on both nodes, they just play ping pong with the state. And sometimes ipv6 vips are on both nodes "master", thats absolutly crazy. As soon as i removed the ipv6 vips all was fine again.

    Seems like it is stil a long road for pfsense with usable ipv6 support :(

  • What you're describing is far from the norm with 2.1, it's very stable at this point. IPv6 support has been usable for nearly 2 years. The missing function sounds like you have a package that's overwriting base system files, like widescreen. I wouldn't ever recommend using it since it overwrites base system files.

    The server load balancer should be fine with v6. You have to create a virtual server that listens on a v6 IP, it doesn't just bind to everything, only the specific IPs and ports you have configured.

  • maybe i just have bad luck then. Yes the widescreen could be the problem, i had that installed before the update. Stil cant figure out why ipv6 carp is going nuts, but now one the master node i just added 2 ipv6 ip as alias interfaces. They can be pinged. I added a virtualserver with the same ips, but they have a IPV4 Pool, maybe thats not supported and i also need to speak ipv6 in my internal lan?

  • Sounds like we're missing input validation to prevent unsupported configs in the underlying relayd, you can't have v6 on one side and v4 on the other.

Log in to reply