Intel 82574L



  • Hello
    We've a new Supermicro 5015a-ehf-d525  ( http://www.supermicro.com/products/system/1u/5015/sys-5015a-ehf-d525.cfm )

    Our issue is that the on board nics do not work with 2.0.1 or 2.1-BETA1 (i386) built on Sat Dec 15 00:36:37 EST 2012  FreeBSD 8.3-RELEASE-p5

    We do have an  dual intel 1000 add on nic which works fine as em0 and em1 .

    According to the sm specs the on board nic is a : 2x Intel 82574L Gigabit LAN .

    Does anyone have a suggestion to get the nics working?

    thanks
    Rob

    PS
    dmseg display nothing when a patch cable is attached to the on board nics.

    and so trying to assign those nics from the console fails.



  • I have a Intel S1200KP mini-itx board, which has a 82574L and 82579 and they both work just fine on 2.0.1 x64 (full install on SSD).



  • @robfantini:

    Does anyone have a suggestion to get the nics working?

    Please post the output of pfSense shell command```

    dmesg ; pciconf -l -v ; ifconfig



  • Just for info, I have a Soekris 6501 with 4x Intel 82574L Gigabit Ethernet ports and it's running happily 2.1 for about a year now. So I guess the drives should not be the problem.



  • When I ran:   1) Assign Interfaces    .   plugging in a patch cable would not help auto assign the interfaces.

    using these :

    
    cat /var/log/dmesg.boot
    pciconf -lvb
    ifconfig -a
    
    

    I was able to determine that the operating system recognized the nics.

    So manual assignment worked.  I used plugging in a cable and running dmesg from cli to determine the em numbers for the 4 nics.

    Thank you for the responses here and at pfSense support.


Locked