[Resolvido] Problemas Timeout SEFAZ - GO



  • Boa tarde.
    Galera talvez alguém tenha alguma sugestão do que possa ser.
    Tenho uma aplicação que envia comunica com webservice do sefaz goias.
    Pois bem o que esta ocorrendo com muita frequência e que aplicação esta tendo muito timeout.
    Fiz o seguinte teste para diagnosticar o problema.
    Se eu deixar a regra default do pfsense tudo que for sair pela lan ele deixar passar não tenho problemas de timeout da aplicação.
    Agora se eu criar a regra falando tudo que sair da lan com destino ao webservice do sefaz go acusa muito timeout.
    Em anexo o meu rules caso alguém tenha ideia.
    Pensava que poderia ser o link mas como informei se eu deixar a regra padrão o problema de timeout não ocorre.
    Obs.
    Atraz deste pfsense só tenho uma maquina rodando esta aplicação.
    O mesmo problema ocorre no meu outro pfsense que esta em produção.
    Estou fazendo lab para tentar encontrar o que pode ser.
    Agradeço sugestões.
    Rodando o tcpdump vejo os ips que foram colocado ali no alias



  • gilmarcabral,

    veja via tcpdump o que mais esta aplicação acessa, deve estar faltando algum ip na sua regra.



  • Bom dia.
    Pelo testes meus o problema esta ocorrendo pois utilizo o Firewall: NAT: Outbound manual.
    Retirei as regras e o problema parou de ocorrer.
    Eu utilizo o Firewall: NAT: Outbound manual pois tenho que permitir o acesso a uma rede via satelite cujo o gw desta rede é 192.168.1.1 e a rede 192.168.50.0.
    Agora a rede lan do pfsense é 192.168.1.0 é o pfsense é 192.168.1.8.
    Agradeço



  • Bom dia.
    Galera eu novamente.
    Verifiquei que o problema de timeout só ocorre quando deixo a regra de direcionamento de tudo que sai da porta 80 para a 3128 do proxy.
    O mais interessante que este timeout da aplicação não ocorre com frequência. ela pode ocorrer em 5 e 5 minutos mas tambem pode ocorrer de 1 em 1 minuto como também de 1 em 1 hora.
    Usei o tcpdump para monitorar os ips liberei tanto os IP como também o domínio do sefaz.
    Fiz o teste de uma estação ligada no pfsense com link de 1 MB dedicado e o problema ocorre.
    Testei tando com um link dedicado de 1 MB como um de 4MB e ambos apresentaram o problema.
    Então o problema não é o link pois quando libero a regra default o timeout não ocorre em ambos os links.



  • Qual versão do squid voce esta usando?



  • Bom dia.
    Marcell estou utilizando o squid3.
    Mas estou liberando no rules tudo que for com destino ao dominio nfe.sefaz.go.gov.br esteja liberado.
    Estou testando mas parece que descobri o problema.
    Eu criei um alias liberando a url: nfe.sefaz.go.gov.br.
    Acompanhando pelo tcpdump para verificar notei que ele só conecta neste domínio não dando ver todos IP que ele utiliza.
    Então pesquisando no google encontrei os IPS que este domínio utiliza que são:
    200.230.57.0/25, 189.2.188.128/26, 187.5.111.0/25, 201.48.19.0/26.
    Liberei eles e estou fazendo testes.
    Por enquanto o problema de timeout não ocorreu mais.
    Estou testando ainda.
    Posto aqui novidade se realmente foi resolvido.



  • @gilmarcabral:

    Marcelloc, estou utilizando o squid3.
    Por enquanto o problema de timeout não ocorreu mais.

    Verifique também se a opção dns_v4_first está habilitada no squid.



  • Boa tarde.
    Resolvido.
    O problema que o dominio sefaz possui vários IP.
    Liberei todos IPS do dominio é foi resolvido.
    Agradeço


Locked