Problem with OpenVPN Client Export Utility package



  • There seems to be a problem with the OpenVPN Client Export Utility package in 2.1. The package installs fine but when I go through the upgrade process to upgrade to the latest snapshot the system gets stuck on the "Packages are currently being reinstalled in the background. Do not make changes in the GUI until this is complete." page. If I open a console what I find is that it's stuck at "Installing OpenVPN Client Export Utility and its dependencies. 100% 100% 100% 30%" and that last package never seems to get past the 30% no matter how long I wait.

    I have learned that I can Ctrl+C in the console and get it to move past the broken package, get into a shell and then exit out of the shell and the system will continue going but the package is clearly broken as once I do that I no longer have the Client Export tab on the OpenVPN page. I can then go back in to the web interface and remove and then reinstall the client export utility package and it will install correctly.

    Thoughts? Thanks!


  • Rebel Alliance Developer Netgate

    Interesting. I have that package loaded on nearly every VM I've got and real hardware also, and regularly track 2.1 snapshots, and I've never seen that behavior.

    I uploaded new copies of the binaries for OpenVPN Client Export yesterday as a part of other things being done, it might be worth trying it out again.



  • I can ack to jimp - the export utility continued working over a dozen of daily build updates so far.

    So much about "Have tried reinstalling it once again" ? :-)


Locked