Dual line MLPPP, one line drop causes failure



  • pfsense 2.01 amd64bit.
    I have two DSL lines, using MLPPP. When both lines are up, they work correctly giving me a bonded speed.
    When one line is down, the internet browsing is very sluggish, some pages load, some just hang and timeout. I can ping/tracert web sites ok, the ping times are ok too.

    When I unplug one line (or power off one DSL modem) I get these normal errors. When I reconnect the 2nd line, it quickly reconnects and the system operates as normal.

    Dec 18 16:50:33 ppp: [wan_link0] Link: reconnection attempt 50
    Dec 18 16:50:31 ppp: [wan_link0] Link: reconnection attempt 50 in 2 seconds
    Dec 18 16:50:31 ppp: [wan_link0] LCP: Down event
    Dec 18 16:50:31 ppp: [wan_link0] Link: DOWN event
    Dec 18 16:50:31 ppp: [wan_link0] PPPoE connection timeout after 9 seconds
    Dec 18 16:50:22 ppp: [wan_link0] PPPoE: Connecting to ''
    Dec 18 16:50:22 ppp: [wan_link0] Link: reconnection attempt 49
    Dec 18 16:50:19 ppp: [wan_link0] Link: reconnection attempt 49 in 3 seconds
    Dec 18 16:50:19 ppp: [wan_link0] LCP: Down event
    Dec 18 16:50:19 ppp: [wan_link0] Link: DOWN event

    Any ideas on where to look for the errors/solution?



  • Any updates on solutions. I have finding the same issue, i am on amd64 as well.

    Jacob



  • I get the same.

    I believe it has to do with the MTU being too large for one line.  I haven't had any real time to test this theory.



  • Still operates like this, MLPPP provides no line redundancy, if one line is down, the whole internet connection is down.

    I'm on the latest 2.1 beta.

    I'm open to testing if someone would offer steps to test.



  • Olypen messed up this week, they moved a bunch of circuits from somewhere to somewhere, is what they told me, breaking MLPPP.
    So they shut off one of my DSL lines.

    Now I can connect kinda to some sites partially, mostly google sites for some reason, but most connections don't work. Ping works fine.

    I went into the config and deleted an interface from my MLPPP PPP interface so that I at least have a working internet connection.

    Any ideas on what I can change to make the lines redundant in a normal situation? Change the MTU to what?



  • Olypen broke me also this last week.    ::)

    I tried lowering the MTU on my computer here to access the network but it didn't work. Still testing however.

    This is an issue though.  MLPPP is supposed to work fine when reduced to one line.



  • I noticed that the ip address has updated to a location back in Western WA, previously it said it was in Kennewick. So maybe its almost fixed. They said it'd be fixed by the end of this week, I shall see.

    I spoke to tech support, they did say one other user was affected, that'd be you then.  :(

    Have you used any other mlppp capable device that continued to work when a line went down?



  • Have you used any other mlppp capable device that continued to work when a line went down?

    No.

    I need to try but Im going off users comments such as Tomato en such.

    The site is a remote one at this point and I can't reach the firewall at all.



  • Maybe it is up to the isp to correctly route the traffic, as this isp description suggests here: http://www.acanac.ca/mlppp-internet.html

    Olypen told me that they disabled the pppoe authentication on the 2nd dsl line until they fix the issue.
    Up until this morning I left the 2nd line continually trying to connect, but that stopped working, I had to remove an interface from the wan interface.

    I have a router than I can try OpenWrt/MLPPP on, I have tried TomatoMLPPP and that didn't work when one line went down.



  • Thanks for the info.

    As of now I am still down and need to explore other options I suppose.



  • Both my lines are working now but I want to know if there is a way to overcome the none redundancy with pfsense.

    Do I file a problem report somewhere?

    http://download2.mikrotik.com/what_is_routeros.pdf RouterOS , been reading about it, ever tried it?



  • When I talked of other options I meant the ISP btw…

    But no- I looked at their website a couple of years ago but thats as far as I went.

    My belief is that Olypen needs to do something on their end, but as this is new to them Im not sure it will happen quickly.

    Im curious what change they made that messed things up and may go down to their office today if I get time.



  • I sent the isp an email asking them this.

    Let us know what you find out from them. I'm tempted to try RouterOS.

    They told me this:
    The issue with your MLPPP setup was due to an upgrade we made in our system. We copied the existing running config, and it appears that with the upgrade, additional changes had to be made. The reason that your connection was not working when your second modem was active was due to both of them attempting to run as individual circuits and not being bonded.
    The next time either of your circuits drop, the MLPPP bundle should disable and the circuit single circuit should still work and depending on how your router functions, no changes should be needed.

    I will try disconnecting one line myself and seeing what happens later.