Squid Cannot Start On 2.1 Beta 1 AMD 64



  • I've noticed that something is broken since the 17th December Snapshots with Squid not being able to start. I've done fresh installs on the snapshots of the 19th with the same results:

    Dec 20 22:16:32 check_reload_status: Syncing firewall
    Dec 20 22:16:33 php: /pkg_edit.php: [squid] xmlrpc sync is starting.
    Dec 20 22:16:33 php: /pkg_edit.php: Starting Squid
    Dec 20 22:16:33 php: /pkg_edit.php: The command '/usr/pbi/squid-amd64/sbin/squid -f /usr/pbi/squid-amd64/etc/squid/squid.conf' returned exit code '1', the output was '2012/12/20 22:16:33| cache_cf.cc(381) parseOneConfigFile: squid.conf:6 unrecognized: 'dns_v4_first''
    Dec 20 22:16:34 php: : SQUID is installed but not started. Not installing "nat" rules.
    Dec 20 22:16:34 php: : SQUID is installed but not started. Not installing "pfearly" rules.
    Dec 20 22:16:34 php: : SQUID is installed but not started. Not installing "filter" rules.
    Dec 20 22:16:43 check_reload_status: Reloading filter
    Dec 20 22:16:45 php: : SQUID is installed but not started. Not installing "nat" rules.
    Dec 20 22:16:45 php: : SQUID is installed but not started. Not installing "pfearly" rules.
    Dec 20 22:16:45 php: : SQUID is installed but not started. Not installing "filter" rules.



  • Some changes were made on the squid3 .pbis the last few days. Try to reinstall squid3.


  • Rebel Alliance Developer Netgate

    That error specifically should be fixed by the PBI that uploaded last night. A reinstall should let it work now.



  • I re-installed (auto updated) this afternoon (21th of December) around 17:00h (CET Central European Time)
    I still experience the dns_v4_first error and need to "fix" that manually in order to get Squid and Squidguard running.
    Will try again tomorrow.


  • Rebel Alliance Developer Netgate

    New binary just uploaded. Give it another try now.



  • Thanks.

    It is now working Jimp.

    This is the relevant output from the log:

    Dec 21 22:46:46 dhclient: XMT: Solicit on em0, interval 8640ms.
    Dec 21 22:46:46 check_reload_status: Updating all dyndns
    Dec 21 22:46:47 php: : SQUID is installed but not started. Not installing "nat" rules.
    Dec 21 22:46:47 php: : SQUID is installed but not started. Not installing "pfearly" rules.
    Dec 21 22:46:47 php: : SQUID is installed but not started. Not installing "filter" rules.
    Dec 21 22:46:49 check_reload_status: Restarting ipsec tunnels
    Dec 21 22:46:51 php: : Creating rrd update script
    Dec 21 22:46:51 php: : Restarting/Starting all packages.
    Dec 21 22:46:52 php: : Starting Squid
    Dec 21 22:46:52 squid[71348]: Squid Parent: child process 71752 started
    Dec 21 22:46:52 check_reload_status: Reloading filter
    Dec 21 22:46:52 php: : Not calling package sync code for dependency squidreverse of squid3 because some include files are missing.
    Dec 21 22:46:55 dhclient: XMT: Solicit on em0, interval 17460ms.
    Dec 21 22:46:56 login: login on ttyv0 as root
    Dec 21 22:46:56 sshlockout[89176]: sshlockout/webConfigurator v3.0 starting up
    Dec 21 22:47:13 dhclient: XMT: Solicit on em0, interval 35540ms.


Locked