Latest update 12/23 failed to reinstall pfblocker



  • So I just ran the update to move from a version of 2.1 beta released late last week, to today's (12/23/12) snapshot.  After the upgrade was completed, I noticed that pfBlocker is no longer in the menus.  Still investigating but I didn't notice anything really out of the ordinary.  I always get a DXIOCOMMIT error when starting up from a reboot, accompanied by one of two snort interface configs failing to go active.  But a service restart on Snort fixes that.  I've not had a package disappear before though so this one is new to me.  Ideas?

    ============
    Update:  A little more info from PHPerrors:

    [2.1-BETA1][admin@storm.vip-host.local]/tmp(73): more PHP_errors.log
    [23-Dec-2012 19:56:06 UTC] XML error at line 1, check URL
    [23-Dec-2012 21:34:29 UTC] PHP Warning:  include(/usr/local/www/widgets/widgets/pfBlocker.widget.php): failed to open stream: No such file or directory in /usr/local/www/index.php on line 712
    [23-Dec-2012 21:34:29 UTC] PHP Warning:  include(): Failed opening '/usr/local/www/widgets/widgets/pfBlocker.widget.php' for inclusion (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /usr/local/www/index.php on line 712
    [2.1-BETA1][admin@storm.vip-host.local]/tmp(74):

    ====================

    And even more curious, it appears that the update didn't happen at all as I'm still running Saturday's code even though I ran the update after Sunday's code had already been posted:

    A new version is now available

    Current version: 2.1-BETA1
          Built On: Sat Dec 22 08:15:29 EST 2012
        New version: Sun Dec 23 12:23:39 EST 2012

    Update source: http://snapshots.pfsense.org/FreeBSD_RELENG_8_3/i386/pfSense_HEAD/.updaters

    And even more curious, see graphic of config changes.  It looks like an unknown config change was written during the package "reinstall" phase that may have "canned" pfBlocker from being reinstalled on the system.

    Thanks,
    David


Locked