Getting Kernel Panic after 2.0.2 upgrade



  • Hello All,
    I have upgraded to 2.0.2 with firmware upgrade wizard. After that I am getting kernel panics.
    The main issue looks like the error below. Also I have uploaded all the reports to the dropbox.
    I am using this pfsense with snort installed and I have 4 bce nics (2 active).

    Please help.

    Fatal trap 12: page fault while in kernel mode
    cpuid = 0; apic id = 00
    fault virtual address = 0x370
    fault code = supervisor read data, page not present
    instruction pointer = 0x20:0xffffffff808f1d9d
    stack pointer        = 0x28:0xffffff800009bb00
    frame pointer        = 0x28:0xffffff800009bb30
    code segment = base 0x0, limit 0xfffff, type 0x1b
    = DPL 0, pres 1, long 1, def32 0, gran 1
    processor eflags = interrupt enabled, resume, IOPL = 0
    current process = 12 (swi4: clock)

    My full crash reports are here:
    http://dl.dropbox.com/u/30087341/pfsense/pfcrash-report20121225-01.txt
    http://dl.dropbox.com/u/30087341/pfsense/pfcrash-report20121225-02.txt

    Alper



  • Upgraded from what version? What are those custom /usr/local/etc/rc.d/ scripts you have there?



  • Upgraded from 2.0.1,
    in the files there is ipv6 options i found on internet, but it does not work.

    link i found it:
    http://remcobressers.nl/2009/08/



  • I'd take out those IPv6 scripts, that page is very dated and should no longer be used, if you need IPv6 you have to use 2.1. There are some OS-level issues in the base of 2.0.x with IPv6 that could cause kernel panics in certain circumstances. That may or may not be the issue. The base OS is no different between 2.0.1 and 2.0.2 aside from the security fixes, none of which would cause any stability issues. My guess is if it isn't the IPv6, you've developed a hardware problem coincidental to the upgrade. Otherwise something else unrelated to the upgrade itself changed.



  • Thank you for your reply. I have removed the scripts,
    If the problem continues I will check the hardware with some testing tools and I will try a clean installation of 2.0.2.
    Regards



  • After removing the scripts everything works fine.
    Thank you for your support!
    Happy New Year!

    Regards.
    Alper


Locked