2.1/postfix



  • Having mostly recovered from a major problem with updating to 2.0.2, I updated an old 2.1 VM with the firmware from Dec 24.  Still had a couple of problems with postfix though.

    Postfix was refusing to relay so I copied the files from /usr/local/etc/postfix to /usr/pbi/postfix-i386/etc/postfix - sort of as recommended here:
    http://forum.pfsense.org/index.php/topic,56433.msg301727.html#msg301727.  That seems to have worked.

    I also had a problem with this error:

    postfix/postfix-script[62267]: warning: not owned by root: /var/spool/postfix
    

    but chown fixed that (and doesn't seem to break anything else).

    When postscript starts, though, I still get this in the log:

    php: : The command '/usr/local/sbin/postfix reload' returned exit code '1', the output was '/usr/pbi/postfix-i386/sbin/postconf: warning: /usr/pbi/postfix-i386/etc/postfix/master.cf: unused parameter: user=postfix'
    
    

    I know that postfix on 2.1 is probably not even close to ready but it does seem to be working now.

    Should I be worried about this last error or any of the other "fixes" I've made?  Is there a simple way to eliminate this last error?

    Thanks


Locked