Update 1.2-BETA-1 for 1.2-BETA-2



  • Hi,

    I tried updating 1.2.Beta-1 to 1.2-BETA-2 today a couple of times but the system still says i have 1.2-BETA-1
    built on Mon Apr 30 11:14:16 EDT 2007.

    When i take a look in the system log it shows these entries;
    09-07-2007 16:02:51 Daemon.Info pfsense.local Jul  9 16:02:53 Upgrade[4015]: Firmware upgrade in progress…
    09-07-2007 16:02:56 Daemon.Info pfsense.local Jul  9 16:02:58 Upgrade[4043]: Installing /root/firmware.tgz.
    09-07-2007 16:02:56 Daemon.Info pfsense.local Jul  9 16:02:59 Upgrade[4049]: Image installed /root/firmware.tgz.
    09-07-2007 16:02:58 Daemon.Info pfsense.local Jul  9 16:03:00 UpgradeFlags[4106]: cat changed
    09-07-2007 16:02:58 Daemon.Info pfsense.local Jul  9 16:03:00 UpgradeFlags[4106]: <009>permissions expected 0555 found 0755 modified
    09-07-2007 16:02:58 Daemon.Info pfsense.local Jul  9 16:03:00 UpgradeFlags[4106]: chflags changed.
    //snap
    A lot of permission entries.
    And in the end;
    09-07-2007 16:03:01 Daemon.Info pfsense.local Jul  9 16:03:03 UpgradeFlags[4118]: <009>permissions expected 0444 found 0644 modified
    09-07-2007 16:03:01 Daemon.Info pfsense.local Jul  9 16:03:03 UpgradeFlags[4118]: share/zoneinfo/zone.tab changed
    09-07-2007 16:03:01 Daemon.Info pfsense.local Jul  9 16:03:03 UpgradeFlags[4118]: <009>permissions expected 0444 found 0644 modified
    09-07-2007 16:03:12 Daemon.Info pfsense.local Jul  9 16:03:14 Upgrade[4153]: Done.
    09-07-2007 16:03:26 Auth.Notice pfsense.local Jul  9 16:03:29 shutdown: reboot by root:

    I am a newbie so i don't know if thats good or not.
    Also when loading pfSense-1.2-BETA-2-Embedded-128-MB.img.gz the firmware gives me a warning;
    The digital signature on this image is invalid.
    This means that the image you uploaded is not an official/supported image and may lead to unexpected behavior or security compromises. Only install images that come from sources that you trust, and make sure that the image has not been tampered with.
    Do you want to install this image anyway (on your own risk)? (I answered yes).

    Is there a solution for this other then writing the the new image to the CF card with a physicaldiskwrite?

    regards,
    Hellsblade





  • Thank you Scott,

    That did the trick (a case of "Read The Funny Manual" i suppose  :-[)
    but… after doing the upgrade wich took half an hour, i was left with an unresponsive system.
    I tried rebooting a couple of times, but no luck.

    So i did the physicaldikwrite anyway and restored my backup.

    Everything seems to work, except for the captive portal on the WIFI interface. I disabled it for the time being to do some further testing.

    One more question is there a way to backup the rrd database to an external system adn restore it later?

    rgds,
    Hellsblade


Log in to reply