DynDNS & No-IP aren't updating ?



  • I am sure this is something I am doing wrong.  I have a dynamic IP from Comcast and a no-ip account.  I had a dyndns account as well and was getting the same result with it not updating after the IP change.  Under the dyndns tab in pfsense, it shows the correct ip in green. On the dashboard everything appear correct as well.  When I try to connect back to the no-ip dns name within my openvpn config file, dns is resolving to an old comcast IP from a few days ago.  When I do an nslookup or traceroute I get the same old IP.

    pfsense appears I checked in the system logs and found this?

    Dec 25 11:47:19 php: : Dyndns debug information: Could not resolve checkip.dyndns.org to ip using interface ip 192.168.100.20.
    Dec 25 11:44:11 check_reload_status: Updating all dyndns
    Dec 25 11:23:37 check_reload_status: Updating all dyndns

    I am using a no-ip.org dns name and selected no-ip.org in the configuration so I am not sure why it's checking dyndns.org? Not sure is this hit is even for the pfsense box given it's using a dhcp address.  I don't recall having any other boxes with dyndns accounts.

    Under my dynamic dns config, I don't have a MX record or a wildcard enabled.  The rest appears to be correct as in "no-ip.org" is selected along with my full hostname, username, and password.

    Thanks in advance.


  • Rebel Alliance Developer Netgate

    It's checking that site because your WAN has a private IP, and it's trying to determine the real, public IP, so it can update the remote service.

    It would probably work more reliably if your WAN had a public IP on it directly. Can you change your cable modem into a bridge or passthrough mode so that the firewall gets a public IP?



  • My wan shows a public ip on the dashboard.  I will check into my modem.  Thanks



  • @newbieuser1234:

    My wan shows a public ip on the dashboard.

    But your system log says:
    @newbieuser1234:

    Dec 25 11:47:19 php: : Dyndns debug information: Could not resolve checkip.dyndns.org to ip using interface ip 192.168.100.20.
    Dec 25 11:44:11 check_reload_status: Updating all dyndns
    Dec 25 11:23:37 check_reload_status: Updating all dyndns

    Perhaps your pfSense dynamic DNS is NOT configured to watch the WAN interface? Or you mistakenly think 192.168.100.20 is a public IP address.

    What version of pfSense are you running?



  • i understand your point and i don't think that is a public ip.  i switched from no-ip to dyndns and it's working now.


Locked