Compaq Deskpro EN series - Fails to reboot from Gui or CLI



  • I am running pfs 2.0.1 on old SFF Compaq - all seems now to be running well.  I am having some issues with maximum speed (separate thread) but otherwise all working perfectly.

    Apart from one problem - cannot reboot from either gui / cli.  Unlike some other threads my system gets all the way to "rebooting" - even to the point that the monitor shows that the server has stopped sending any video signal.  But then it just stops - still showing power to server, but no physical reboot.  Only option at that point is the power button - which works fine, bringing everything back up running.

    Based on other threads I have tried:

    You can try setting this options in /boot/loader.conf
    hw.acpi.handle_reboot=1
    or
    hw.acpi.disable_on_reboot=1
    Please try them separately and see if they make a difference.

    No difference.  Also tried every combination of BIOS settings for power etc (Old PC - very few options) again with no success.

    Manually trying shutdown -r now also has exact same result.

    Prior to running BSD/pfs on this PC I was running (slowly!) XP - which rebooted from command perfectly - as did previously alt-ctrl-del in MS-DOS.

    Any further suggestions appreciated

    TIA



  • Is the BIOS "up to date"?



  • Yes - has latest BIOS - dated 2002.  No newer BIOS available for this model :)

    Any further thoughts?


  • Netgate Administrator

    Compaq always did like to go their own route with bioses and case design. You may be out of luck here. The fact that it reboots fine in Windows is not a good test since bioses always have lots of specific code for Windows and usually one small section for 'other' OSes. Have you tried booting it from a live Linux distro for example? That would be a better test.

    As much as I'm in favour of reuse/recycling it may be time to retire that P2. I'd say you've had your moneys worth from it! ;) I have whole bunch of machines here that are all faster that can't justify holding onto longer.

    Steve



  • Unfortunately it doesn't reboot from Linux / BSD directly either.  Have had a search around and found many instances of the same problem (several years ago) but with no apparent solution.

    Unless anyone can suggest a way to emulate a windows reboot I think I am out of possibilities.

    It is a shame as I have two of these old Compaqs that were sitting on a shelf for years - and pfs seemed the ideal tool to make them useful again. They are very small and almost silent - plus they take full height NICs, unlike most SFF PCs that need higher priced low profile. As I don't have any other spare units lying around I will continue to use them for now - living with the reboot issue.  Hopefully they remain stable so that the reboot problem is effectively irrelevant.

    Thanks for the suggestions - will hope that someone comes up with a novel solution!!

    ….................

    Just come across this as a possible solution elsewhere:

    I get this problem unless I boot with reboot=pci in my kernel args.

    Not sure if this relates to building the kernel - or something that could be loaded?  (Way out of my comfort zone!)  Any thoughts?


Locked