Web GUI shows CPU @ 100%



  • The web gui running pfsense 2.02 RELEASE Build always shows my cpu @ 100%. but when i run top. it shows max 13%-15% usually sits at around 6%-8%. I dont know why it does this. Although i just installed pfsense for the first time. Its a P4 with 512ram.

    Anyone? Idea?


  • Netgate Administrator

    The dashboard itself can use a significant amount of cpu time in low end systems. What sort of P4 is it? It wouldn't be 100% though.
    What do you see if you run 'top -SH' which also shows system processes?
    What if you have the dashboard open and run top via ssh at the same time?

    Steve



  • Its a P4 2.4 32 bit no HT, its a very basic one. Not sure the exact model number.

    When i run top -SH vs just top. the percentage range is about the same, There are more processes little over double the processes.

    And yes even with the web GUI open or closed its still about the same it never passes 15-16% now with SH i just saw 19% with one comp downloading @ 2000+ KB/s.

    Regardless the web gui is always showing me 100%. I even tried it with Firefox same thing.

    I think its a bug. But wanted to see what the forum has to say about it.


  • Netgate Administrator

    Hmm, does seem like a glitch.
    The only other thing that often confuses people is the use of device polling. If this is enabled you will see 100% CPU. I would expect to see that with top as well though.

    Steve


  • Rebel Alliance Developer Netgate

    If the system is loaded enough (or slow enough) then the load of running the WebGUI dashboard updates can be enough to make it show 100% in the widget. It will always show higher in the GUI because the GUI takes more CPU time to render.

    Using top from the shell isn't using the GUI at all, so that part is practically idle.


  • Netgate Administrator

    Yes but look at the increase in cpu loading between top and the GUI (15% to 100%). Compare that with the system spec (P4 2.4GHz). I have a hard time believing this is a correct reading.

    Steve



  • ya it was some sort of glitch. i did a factory default reset and now it works fine.

    thank you all.


Locked