Static ARP entries do not stay



  • Hello,

    I'm not sure whether this is a pfSense or a FreeBSD bug (or even if it is a bug), but here i go:

    I've a setup where my pfSense 2.1-BETA1-i386-20121228-1654 lies behing my ISP's router. To be able to send WOL packets over internet, i've entered static ARP entries in pfsense via the shellcmd plugin:

    
    arp -s 192.168.100.111 xx:xx:xx:xx:xx:xx
    arp -s 192.168.100.120 yy:yy:yy:yy:yy:yy
    
    

    I've double checked the -s parameter which stays for "static".
    But after 5 minutes these ARP entries get cleared.

    I've to use

    
    arp -S 192.168.100.111 xx:xx:xx:xx:xx:xx
    
    

    for ARP entries to stay.
    I'm pretty sure this ain't the biggest bug report ever, but at least maybe it will save a bit time for Wake On Lan Wan DIY guys.
    Btw, i've NATTED some of my ISP's router ports to port 7 & 9 of my pfSense in order for WOL packets to be transmitted, and it works great.

    Cheers.



  • Refer to the FreeBSD ARP (arp) manual page.  Particularly the -S option.  I think the answer is there.

    Capability for creating static ARP table entries from DHCP static mappings is available in Services: DHCP Server.

    See attached document for additional WoL configuration details.  (remove the .jpg extension)

    [Wake on LAN.docx.jpg](/public/imported_attachments/1/Wake on LAN.docx.jpg)


Locked