Local DNS resolution not working



  • I'm not sure why, but DNS resolution of hosts on my LAN is not working.  I'm running 1.2 Beta 2.  I have a domain name setup in the General section.  I also have the DNS Forwarder enabled, with options to register both DHCP leases and static DHCP leases in DNS.  But I still can't ping hosts via their FQDN.  I even checked the ARP table in pfSense, and the entries are there.  Any ideas?



  • How is your WAN configured? If static, you need to enter DNS server IP's on the General page.



  • WAN is configured as DHCP.  What else can I check?



  • When you go to Status > Interfaces, does it show DNS servers there under WAN? On the General page, do you have the "allow override" box checked?



  • DNS servers are listed under the WAN section.  And yes, the "allow override" box is checked.  I also manually entered the LAN IP address of my pfsense box in the DNS Servers section.

    I also want to mention that local DNS resolution was working properly before.  It may have stopped working when I updated pfSense from 1.2 Beta 1 to 1.2 Beta 2.



  • If you go to the ping page on pfsense, can you ping domain names from there?



  • I am able to ping LAN hosts via the ping page on the pfsense box successfully.  Even if I enter the short DNS name, it will come back as the FQDN on the LAN and ping successfully.



  • If there aren't any more suggestions (but I do appreciate the troubleshooting, cmb), I'm going to make an educated guess about my issue.  Since DNS was working before when I was running 1.2 Beta 1, and I haven't heard anyone else having local DNS issues on 1.2 Beta 2, I'm going to assume my issue popped up when I did the update to 1.2 Beta 2.

    I think that the easiest route for me to resolve this problem is to re-run the Setup Wizard from the web interface.  Of course, I will make a backup before doing so.  But does anyone know what configuration settings I might lose from running the Setup Wizard?



  • I lost power on my pfSense box when a storm hit today.  When it came back up , local DNS started working again.  No clue why that worked (because I have tried rebooting) or if it was a coincidence, but whatever!



  • I have the same issue.

    My hosts can't resolve internal FQDNs. But they can resolve external. I have also checked the different settings as adviced earlier. And they are as they should be.

    I have had this problem before, and it was corrected by a reboot of the router.

    My version is:

    1.2-RELEASE
    built on Sun Feb 24 17:04:58 EST 2008




Log in to reply