Problems with Sarg and View report



  • I wanted to make a post, even though I have solved the issue on my own. (partly)

    I started out with the error, while trying to view report, that it could not find the index.html. I read in multiple places that the issue was from create index.html not being changed in the configuration.

    My problem with this was that using ctrl + click for some reason would not change anything. (well it did let me change one setting, which I don't remember what it was, but other than that, I couldn't change anything from no to yes)

    I finally went into /usr/local and ran rm -rf sarg-reports, then to /usr/local/etc/sarg and edited the sarg.conf file with vi, ran sarg -x (again) which completed successfully.

    I now have reports!  ;D.

    P.S. I had to delete the sarg-reports directory because the command failed with an error before trying that. (sorry, don't remember the error).

    I LOVE pfsense! Thank you to all who contribute to it.



  • The "yes" and "no" in braces is just the default setting. It does not indicate what is activated and what is disabled. It should just show you if this feature/option is enabled by default "yes" or disabled by default "no".

    The options you want to activate must bigh selected. To select multiple options you must use CTRL.



  • Well I had considered that, but it seemed no matter what I tried, nothing worked until I went in and manually edited the config with VI. Although, the problem is not completely sorted out.

    Now if I try to view the report, I get the same error unless I go and force the update, and then try to view the report. For some reason the automatic "updates" to the reports do not work and give me the error about no index file. Once i force the update it works.



  • try to run sarg on console/ssh to see what errors it returns


Locked