Problema em localhost



  • Olá Pessoal,

    Tenho um pfsense na minha rede configurado com mapeamento de DHCP estático e DNS Forwarder habilitado.

    Na minha máquina local x.x.x.10 instalei o xampp. O problema então esta aí. Quando vou acessar o phpmyadmin para criar os bancos coloco o endereço http://localhost/phpmyadmin e ele retorna uma pagina "404 - Not Found (página não existente é claro)", logo em seguida tento acessar a tela inicial do xampp através do endereço http://localhost/index.php e sou imediatamente redirecionado para http://pfsense/ (tela de login).

    Tentei acessar de outra forma usando o endereço de lookback http:// 127.0.0.1/index.php. Agora ele também redireciona para o pfsense, e junto com isso me retorna uma mensagem acima da tela de login:
    You are accessing this router by an IP address not configured locally, which may be forwarded by NAT or other means.
    If you did not setup this forwarding, you may be the target of a man-in-the-middle attack.

    Ou seja, ele ta entendendo o meu endereço de loopback ou como o do pfsense ou ate mesmo redirecionando-me para o mesmo. Só funciona se eu acessar o site pelo http://x.x.x.10/phpmyadmin que é o ip da interface de rede da minha máquina.

    Agora pergunto, porquê isso?



  • Boa Noite Amigo,

    Habilite a opção Disable webConfigurator redirect rule em System: Advanced



  • Habilitei a opção Disable webConfigurator redirect rule. Continua com o mesmo problema.



  • @TonyEmiliano:

    Agora pergunto, porquê isso?

    Está com o proxy marcado no browser desta máquina?



  • Putz, era só isso? Problema resolvido com a desabilitação do proxy nas opções de internet!

    Pode me explicar a causa?



  • @TonyEmiliano:

    Pode me explicar a causa?

    Quando você marca o proxy, a requisição é processada pelo proxy e não pela estação.

    Então se o proxy recebe um http://127.0.0.1, ele vai tentar abrir o http do servidor onde ele esta instalado.

    Você consegue contornar isso definindo no browsers, que endereços você não quer enviar para o proxy.

    att,
    Marcello Coutinho



  • Obrigado.


Locked