Problem whit squidGuard



  • Hi, I have a problem with squidGuard. I need modify the php code but i don't how know modify this.
    Please I post the error and I help you with the test.

    I posted one screen, this show two columns, the second is one error. This cause one error on the squidGuard.conf

    Thanks in advance.




  • I do not see any mistakes. All in configuration matches your GUI settings.



  • my squid guard not filter content

    I can help with this problem

    Example from Squidguard Log

    04.01.2013 14:14:00 : [sg_redirector_base_url]  Select redirector base url (http://192.168.200.1:80/sgerror.php?url=403 &a=%a&n=%n&i=%i&s=%s&t=%t&u=%u)

    Regards,

    Mauricio Niño



  • @mauricioniñoavella:

    my squid guard not filter content

    I can help with this problem

    Example from Squidguard Log

    04.01.2013 14:14:00 : [sg_redirector_base_url]  Select redirector base url (http://192.168.200.1:80/sgerror.php?url=403 &a=%a&n=%n&i=%i&s=%s&t=%t&u=%u)

    Regards,

    Mauricio Niño

    Squidguard config please and GUI screenshots.



  • Hi dvserg

    this file squidGuard.conf

    acl  {
            #
            cerrada  {
                    pass !Lista_P2P_Itac List_Urls_Inter ReportsLinux none
                    redirect 302:http://apache.itac.com.co
            }
            #
            Basica_Ofic_215  {
                    pass !Lista_P2P_Itac List_Urls_Inter ReportsLinux all
            }
            #
            default  {
                    pass none
                    redirect http://192.168.200.1:80/sgerror.php?url=403 &a=%a&n=%n&i=%i&s=%s&t=%t&u=%u
            }
    }

    Regards .
    Mauricio Niño



  • Hi dvserg,

    The SquidGuard configuration changes are applied correctly using the Save and Apply buttons. The problem, at least in 2.0.2, is that no changes actually take effect until you click the Save button on the Squid (Proxy server) configuration page or restart Squid from the command line.

    For example, if I uncheck the "Enabled" checkbox in the SquidGuard configuration and click the Apply button, in 2.0.1 it would remove the redirector_program directive from the Squid configuration and stop the SquidGuard service (which would be reflected on the SquidGuard page by changing the "SquidGuard service state" to STOPPED in red letters). In 2.0.2, the redirector_program directive is properly removed, but the SquidGuard service is not actually stopped… the "SquidGuard service state" text is still STARTED and you can verify this from the command line. Only when you go over to the Squid configuration and click the Save button does the SquidGuard service actually stop.

    This is the case for any changes you make to the SquidGuard configuration... the Save and Apply buttons successfully change the configuration, but the SquidGuard service is never restarted to pick up the changes until you click Save on the Squid configuration page.

    Regards

    Mauricio Niño



  • Mauricio, I send one email a dvserg to explain this problem.
    I can't solve this at the moment.

    dvserg please, we need solve this problem, please send how to we can solve this.

    regards.



  • @mauricioniñoavella:

    Hi dvserg,

    The SquidGuard configuration changes are applied correctly using the Save and Apply buttons. The problem, at least in 2.0.2, is that no changes actually take effect until you click the Save button on the Squid (Proxy server) configuration page or restart Squid from the command line.

    Ok. I will check it in the near time.



  • Hi, dvserg

    excuse for this case, but we know you can help
    we need solve this problem, please send how to we can solve.

    thanks for your colaboration

    regards.

    Mauricio Niño



  • Hello dvserg, I was checking what the buttons save and apply do, at some point the apply button stops the service, it says:
    "squidGuard 1.4 started", then, "db update done" and then appears "squidGuard stopped" I mean, as if the button would do the opposite.

    Otherwise, if I go to the tab "Status + Services" and restart the service, i get up to four messages that say "squidGuard 1.4 started" and "squidGuard ready for requests"

    Is there a way to reverse what the apply button does? I mean, at some point in the upgrade, this button function was changed and was wrong, the service starts and then stops, instead of stop service, and start.  :o

    Kind regards



  • Must be fixed
    Pls reinstall XML and try the test.



  • It's working now, thank you!



  • Hi, dvserg

    It's working now, very well

    thank for your colaboration and working

    regards.

    Mauricio Niño



  • But XMLRCP Sync is giving an error.

    Warning: Invalid argument supplied for foreach() in /usr/local/www/pkg_edit.php on line 423

    Warning: fopen(/usr/local/pkg/squidguard_sync.xml): failed to open stream: No such file or directory in /etc/inc/xmlparse.inc on line 175



  • Hi dvserg,

    The SquidGuard configuration changes are applied correctly using the Save and Apply buttons.

    The problem, at least in 2.0.2, is that the Proxy filter SquidGuard: Groups Access Control List (ACL) on the Squid (Proxy server) configuration
    Transparent proxy mode port 80  not filter

    For example, if I uncheck the "Allow users on interface" on Squid (Proxy server). no filter  SquidGuard
    if I "Enabled"  "Allow users on interface" if filtered  SquidGuard

    but it should work on Proxy server: Access control  if I add "Allowed subnets", if I uncheck the "Allow users on interface" should filtered  SquidGuard, but does not filter

    Regards

    Mauricio Niño

    Thanks for your understanding.



  • @dvserg:

    Must be fixed
    Pls reinstall XML and try the test.

    Thanks a lot dvserg, it's working again…

    I just have this question:  If i update from 2.0.1 to 2.0.2 it's automatically gonna be working or i need to reinstall xml once updated?

    Kindly regards



  • If you update pfsense, then all packages will be reinstalled automatically.
    Further all changes are on pfsense server. Every new install will have the fix dvserg provided.

    @kelsen
    I tried that on two VMs 2.0.1 and didn't get that problem.
    The code is the same as on freeradius2 package or on pfblocker. Just the files which should be synced are different.

    Further I updated pfsense 2.0.1 to 2.0.2 and it was still working.
    Try to reinstall the squidguard package - perhaps something is missing.



  • Thanks for the info Nachtfalke  :D



  • Reinstalling the xml worked at least in one installation. Thx!


Log in to reply