1 website loading very slow, works ok bypassing pfsense. tcp retransmissions



  • I'm having this problem that has been driving me insane for days now. I have pfsense 2.0.2 i386 2g installed on an alix, for some reason i'm unable to reach this website: http://www.ducksoupgaming.com it either refuses to load, or loads very slowly over the course of minutes. MTR's show no loss to the website. wget file transfers happen at less than 1KB/s. If i plug a laptop directly into the cable modem (100mbit plan) the website loads lightning quick, no issues at all.

    I've tried ISP dns servers and google/level3 dns servers, it doesn't seem to be a dns issue. I performed a packet capture and there are a ton of tcp retransmissions (packet capture attached, renamed to .txt). I only really care because that is the tf2 server i frequent and custom map downloads are dependent on reaching that site. Any help would be greatly appreciated, i've tried every setting i could via trial and error including resetting to defaults without success. Thanks!
    [packetcapture (1).txt](/public/imported_attachments/1/packetcapture (1).txt)



  • For the record, I just tried that site through 2 Alix different systems, running 2.0.2 and 2.1-BETA1. The site loads and browses fine via either of them. So there is nothing specially nasty about that site and Alix/pfSense!


  • Netgate Administrator

    Selected websites not loading or slow is almost always an MTU issue.
    http://doc.pfsense.org/index.php/Unable_to_Access_Some_Websites

    By MTR do you mean this? http://en.wikipedia.org/wiki/MTR_(software)

    Steve



  • Thanks for the replies, and yes that is the mtr i am referring to. The site loads fine on my other pfsense installs as well at other locations on different isp's (all cable). I've never had to change the MTU for a cable modem, is there some place to reference for possible changes for charter cable? It's just so strange because that is the only site i've found that is giving me any trouble.



  • I decided to install ipfire on the alix board just to see what happens. I'm not seeing any issues at all running ipfire on the exact same hardware, very strange….


Locked