[Resolvido] OpenVPN - Pfsense 1.2.2 x 2.0.1



  • Boa tarde pessoal!

    Estou com um probleminha bem chato, achei bastante material mostrando configurações para o OpenVPN inclusive demonstrando como deve ser realizado o roteamento das redes porém nada que me auxilie a resolver meu problema.

    Bom é o seguinte: Estou migrando um servidor com PFSense 1.2.2 para a versão 2.0.1, inicialmente já tomei um pau pra conseguir subir todas as VPNs no novo server porém utilizando o campo Advanced configuration e realizando algumas configurações na mão, consegui estabelecer as mesmas o meu problema é que não consigo comunicar com a ponta cliente mesmo utilizando a linha "route 172.16.0.xx 255.255.255.0" no Advanced não vai, com isso fui verificar as tabelas de roteamento através do prompt e comparando a tabela do novo servidor com a do antigo notei diferenças, porém as configurações que eu fiz de roteamento estão iguais a do server antigo.

    Gostaria de saber se alguém já passou por algo parecido ou se alguém sabe se existe diferenças entre o OpenVPN do PFsense 1.2.2 e do 2.0.1

    Vejam as diferenças nas tabelas abaixo:

    Routing tables - (Server NOVO)

    Internet:
    Destination        Gateway            Flags    Refs      Use  Netif Expire
    default            192.168.1.1        UGS         0  5445852    le0
    localhost          link#4             UH          0     1435    lo0
    172.16.0.1         link#9             UHS         5        4    lo0
    172.16.0.38        link#9             UH          0        0 ovpns1
    172.16.0.63        link#19            UH          0        0 ovpns6
    172.16.0.64        link#10            UH          0        0 ovpns2
    172.16.0.65        link#13            UH          0        0 ovpns5
    172.16.0.66        link#12            UH          0        0 ovpns4
    172.16.0.67        link#11            UH          0        0 ovpns3

    –-----------------

    Routing tables - (Server ANTIGO)

    Internet:
    Destination        Gateway            Flags    Refs      Use  Netif Expire
    default            192.168.110.1      UGS         0    12922    vr0
    localhost          localhost          UH          0      500    lo0
    172.16.0.0         link#64            UC          0        1   tap0
    172.16.0.2         172.16.0.1         UH          0        0   tun2
    172.16.0.12        172.16.0.1         UH          0     4611  tun12
    172.16.0.14        172.16.0.1         UH          0        0  tun14
    172.16.0.15        172.16.0.1         UH          0     4660  tun15
    172.16.0.16        172.16.0.1         UH          0     4662  tun16
    172.16.0.17        172.16.0.1         UH          0      687  tun17
    172.16.0.19        172.16.0.1         UH          0        0  tun19
    172.16.0.20        172.16.0.1         UH          0     4838  tun20

    Valew!

    Abraços!



  • Caros!

    Acabo de resolver o problema. Era uma bobagem que eu mesmo fiz.

    Eu estava forçando no "Advanced Configurations" a linha dev-node tunxx, o que equivale ao parâmetro "dev" no pfsense 1.2.2, pelo que entendi o pfsense 2.0.1 não aceita que o seja forçado o dev-tun sendo que o próprio sistema já atribui o valor "ovpns1", 2, 3… e assim por diante, ou seja, sua vpn sempre terá a device identificada por "ovpns + número_sequencia" então não adianta forçar com dev-tun que não funciona, pelo menos é o que estou constatando na prática.

    Se alguém tiver algo pra contribuir  ;)

    Abraço!


Locked