Alix is dead ? (BIOS update without problem)



  • Hi everybody
    I have some "cold sweats" since an hour now.

    I use pfsense 1.2.2 on an Alix 2c3 and thought it was a good idea to upgrade now. I already tried to install pfsense 2.0 on a new CF card some months ago, it failed and I found I had to update Alix BIOS first.

    This evening I tried, using the FreeDOS + alix BIOS update image proposed here. The MD5 sum check was OK
    It had no problem while updating, not even a warning as you can see here:

    01F0 Master 848A TOSHIBA THNCF256MPG
    Phys C/H/S 978/16/32 Log C/H/S 248/32/63
    ….............................................................................FreeDOS kernel build 2036 cvs [version Aug 18 2006 compiled Aug 18 2006]
    Kernel compatibility 7.10 - WATCOMC - 80386 CPU required - FAT32 support

    (C) Copyright 1995-2006 Pasquale J. Villani and The FreeDOS Project.
    All Rights Reserved. This is free software and comes with ABSOLUTELY NO
    WARRANTY; you can redistribute it and/or modify it under the terms of the
    GNU General Public License as published by the Free Software Foundation;
    either version 2, or (at your option) any later version.

    • InitDiskWARNING: using suspect partition Pri:1 FS 06: with calculated values   15-17-49 instead of    1-242-49
      C: HD1, Pri[ 1], CHS=    0-1-1, start=     0 MB, size=    15 MB
      FreeDOS HIMEM64 3.26 [Aug 25 2006] © 1995, Till Gerken 2001-2006 tom ehlert
      HIMEM - Always On A20 method used
      Kernel: allocated 43 Diskbuffers = 22876 Bytes in HMA

    FreeCom version 0.84-pre2 XMS_Swap [Aug 28 2006 00:29:00]
    C:>sb.com
    ALIX flash update (C)2007 PC Engines GmbH
    Flash ID = 1 FFFF GPI = FF
    Flash ID = 0 9D37 GPI = 01
    Reading 512KB flash image alix1.bin….............
    Compare Erase Program Verify - update OK.
    C:>

    And now it's not booting any more, the 3 ethernet link leds light up while the power is connected, and nothing more happens. None of the 3 leds in front flashed, absolutely nothing :(
    Is it dead ?
    I read something about CHS mode, I checked in BIOS before updating and did not change anything, since it was working until this evening.

    I hope I have a solution to recover it !

    Thanks !


  • Rebel Alliance Developer Netgate

    What serial speed are you using to access the ALIX? The BIOS update may have reset the serial speed selection, so if your BIOS was defaulted to, for example, 38400, you would get no output or garbled output if your serial client was set to 9600.

    Try a few different speeds and see if anything turns up.



  • Hi
    I tried 9600 19200 and 38400, I got nothing at all. Is there another speed I should try ?

    Could it be the new BIOS that doesn't light up the three leds at boot ?

    Thanks !


  • Rebel Alliance Developer Netgate

    Not likely. Are you sure you had a ALIX 2c3?

    Only thing I can think of is maybe you flashed it with a BIOS for the wrong board…

    http://pcengines.ch/alix2.htm



  • I'm quite sure it's a 2c3, comparing with other models I don't have a VGA port, only Serial, dual USB + 3 Ethernet + miniPCI

    That's what I was thinking, the wrong BIOS, but I used the image from here: http://doc.pfsense.org/index.php/ALIX_BIOS_Update_Procedure
    (this link: http://files.pfsense.org/misc/alixupdate_0.99h_freedos.img.gz )

    It would be a really bad news if the image is wrong (and not corrupted because md5 is correct)

    I also checked the power supply, it gives around 13V (should be 12V) and tried with another one: same thing

    Thanks for you answers


  • Rebel Alliance Developer Netgate

    I think the 2c3 uses the same bios as the 2d3, but I'm not 100% certain. I do know the "c" series is older than the "d" series so there could be some other differences. I've only ever had my hands on the 2d3 and 2d13 myself.

    The PC Engines page only warned about the BIOS versions for the models with VGA so it may not have been that.

    You might try sending an e-mail directly to PC Engines to see if he has any advice. The guy who runs the place is really nice, he may know what to tell you or at least be able to give a definitive answer.



  • Thans for the advice, I didn't think asking him directly I'll do that (and make a report here if it helps someone else) !

    I also check the differences between 2c3 and 2d3 I didn't see anything on the website, they are very similar, maybe the routing on the board ? nevermind :)



  • You were right ! He is nice !
    He offers me to buy an LPC module (<5$) http://pcengines.ch/lpc1a.htm or to send it as an RMA, which I choose (I had enough problems!)


Locked