No Internet access after successful failover?

  • I have  a normal WAN connection (GW_WAN) and a 3G surfstick connection (GW_OPT8), also intended to be used as WAN.
    I put both in a gateway group called WAN_FAILOVER:

    GW_WAN  Tier1 (Monitor IP
    GW_OPT8 Tier2 (Monitor IP

    Trigger level is member down.

    Additionally I enabled "Allow default gateway switching" in System - Advanced - Miscellaneous.
    In the firewall rules on the VLAN interface where my compuster is connected to, I have set the WAN_FAILOVER group as gateway.

    For testing the failover I removed the WAN (GW_WAN) ethernet cable. System log then looks like this:

    Jan 12 19:42:32 php: : MONITOR: GW_WAN is down, removing from routing group
    Jan 12 19:42:32 php: : Default gateway down setting GW_OPT8 as default!
    Jan 12 19:42:19 apinger: ALARM: GW_WAN( *** down ***

    Routing table also gets updated:

    default UGS 0 184 1492 ppp0

    Any idea why it isn't working? Thanks!

  • Routing looks fine, have you defined the interfaces to use for the dns servers, within General Settings?

    Make sure that they are set and also make sure they are leaving out of the correct interface i.e

    dns server              use gateway                  wan                  opt8

    If you check your routing table you should see

    Destination Gateway Flags UGHS

    Let us know how you get along

  • Abdsalem , thank you very much for your reply! I meanwhile foudn the error: On Firewall: NAT: Outbound the manual rule creation was enabled (needed e.g. if one wants static ports, useful for VoIP). There I only had rules for the normal WAN interface, duplicating those rules and replacing the WAN interface with the failover interface made everything work :-) Also one doesn't need the gateway group and WAN_FAILOVER group as gateway in the firewall rules when having only 2 WAN interfaces. I guess those options are for more advanced things, e.g. 3 WAN interfaces where it isn't clear which one shall be used when the primary one fails.

Log in to reply