How to create an OpenVPN client to IPredator?



  • I tried what not but I am always stuck with:

    openvpn[22491]: UDPv4 WRITE [42] to [AF_INET]93.182.184.130:1194: P_CONTROL_HARD_RESET_CLIENT_V2 kid=0 pid=[ #5 ] [ ] pid=0 DATA len=0
    

    If I use OpenVPN GUI client on windows it connects instantly.
    Here is IPredator conf file:
    https://ipredator.se/downloads/openvpn/cli/IPredator-CLI-Password.conf
    Any idea?

    Thanks.



  • Further reading suggest that message appears if one side can not talk to another which to me does not make sense since I am able to connect from windows which is "deeper buried" inside network than pfsense. Just in case I opened 1194 port for whole range of address 93.182.128.0/18 on WAN side but still nothing.
    I suspect that there is maybe problem by using "client certificate" (using "webConfigurator default") which is not used at all in IPredator configuration (only TLS and CA).
    Is there a way to remove client certificate in web configurator?
    I tried to remove it manually in /var/etc/openvpn/client.conf but it seems that web configurator has precedence.
    I was shooting in dark by running openvpn manualy in shell with their conf file but there is no any screen output (usually should be) even though I see it running (ps ).
    Any advice?

    Thanks.



  • Hi.
    Did you get this to work in the end?
    I ended up whit the same conclusion you did.



  • i installed certificates, but there are some config lines , namely

    
    nobind
    auth-retry nointeract
    
    tls-client
    ns-cert-type server
    
    keepalive 10 30
    tls-cipher TLSv1:!ADH:!SSLv2:!NULL:!EXPORT:!DES:!LOW:!MEDIUM:@STRENGTH
    persist-key
    persist-tun
    tun-mtu 1500
    mssfix
    passtos
    verb 3
    
    

    which i paste in "Advanced" section in https://192.168.1.1/vpn_openvpn_client.php?act=new

    but it still dont work, any ideas?
    why i cannot just upload .conf to config directly?