Big error



  • Hi all

    After I have installed the program where I get up this message.



  • Are you running in a VM? There are other threads about this happening in various environments with different ways of setting clocks/NTP etc. e.g. a recent thread: http://forum.pfsense.org/index.php/topic,57234.0.html


  • Netgate Administrator

    I would hope he wouldn't be sending a photo of a screen if it was a VM, but you never know!  ;)

    Another possibility is a bad kern.timecounter.hardware selection.
    Usually the default choice is TSC. E.g.

    [2.0.2-RELEASE][root@pfsense.fire.box]/root(2): sysctl kern.timecounter.hardware
    kern.timecounter.hardware: TSC
    

    However if your processor has a variable frequency for whatever reason, speedstep, thermal throttling, turbo mode etc, then TSC can vary causing problems.

    You can check what your options are:

    [2.0.2-RELEASE][root@pfsense.fire.box]/root(6): sysctl kern.timecounter.choice
    kern.timecounter.choice: TSC(800) i8254(0) dummy(-1000000)
    
    

    The number is the quality of the time counter, TSC is highest quality as it ticks the fastest. You can choose, say, i8254 instead:

    [2.0.2-RELEASE][root@pfsense.fire.box]/root(7): sysctl kern.timecounter.hardware=i8254
    kern.timecounter.hardware: TSC -> i8254
    [2.0.2-RELEASE][root@pfsense.fire.box]/root(8): sysctl kern.timecounter.hardware
    kern.timecounter.hardware: i8254
    
    

    If that solves the problem you can add the sysctl to the table in System: Advanced: System Tunables:

    Steve



  • On physical hardware, that's usually caused by a buggy BIOS and upgrading it generally fixes. Though mucking with the timecounter sysctls may be a work around, as Steve noted.


Locked