Can't access my POP3/SMPT server from the same ISP…



  • I have a problem in NATing.. I have setup a nat rule that forwards port 25 and 110 from WAN to my local server ip. When accessing this server from different ISP (diferent ext. IP), It works fine.. but when accessing from within the network using server's external ip, i cant get to the server. I can localy… but the poit is that i cant access or send  my mails from my own Internet...  :P

    I have also unchecked the Dissabe NAT reflection and it worked for the www server, but not for the mail server. i also cant access the webmin on my server...

    The nat rules look like that:

    WAN  TCP/UDP  25 (SMTP)  192.168.11.190  (ext.: any) 25 (SMTP) Server SMPT
    WAN  TCP  80 (HTTP)  192.168.11.190  (ext.: any) 80 (HTTP) Server HTTP
    WAN TCP/UDP 53 (DNS) 192.168.11.190    (ext.: any) 53 (DNS) Server DNS 
    [edit rule]
    [add a new nat based on this one]
    WAN TCP/UDP 25 (SMTP) 192.168.11.190
    (ext.: any) 25 (SMTP) Server SMPT 
    [edit rule]
    [add a new nat based on this one]
    WAN TCP/UDP 110 (POP3) 192.168.11.190
    (ext.: any) 110 (POP3) Server POP3 
    [edit rule]
    [add a new nat based on this one]
    WAN TCP/UDP 9999  192.168.11.190
    (ext.: any) 9999  Server WEBMIN

    and the firewall rules :
    *  *  *  192.168.11.190  *  *  NAT Server HTTP 
    [edit rule]
    [delete rule] [add a new rule based on this one]
    [click to toggle enabled/disabled status] TCP/UDP * * 192.168.11.190 53 (DNS) * NAT Server DNS 
    [edit rule]
    [delete rule] [add a new rule based on this one]
    [click to toggle enabled/disabled status] TCP/UDP * * 192.168.11.190 25 (SMTP) * NAT Server SMPT 
    [edit rule]
    [delete rule] [add a new rule based on this one]
    [click to toggle enabled/disabled status] TCP/UDP * * 192.168.11.190 110 (POP3) * NAT Server POP3 
    [edit rule]
    [delete rule] [add a new rule based on this one]
    [click to toggle enabled/disabled status] TCP/UDP * 9999 192.168.11.190 9999 * NAT Server WEBMIN

    For LAN i have all open..

    THX for anwseres



  • Everything except DNS is TCP, not TCP/UDP, so I would change your rules for SMTP/POP, etc to use only TCP. Then it should work with NAT refection on. I would think a better solution would be to use Internal DNS servers with the private numbers, or do split DNS.


Log in to reply