[Resolvido] Servidor DHCP marrado por MAC



  • Boa tarde.
    Galera iniciei a configuração do servidor dhcp no pfsense porem estou encontrando algo que não estou totalmente de acordo.
    Atualmente utilizo servidor dhcp em debian tudo marrado por mac sem range.
    Não defino range inicial e final pois como meu dhcp e todo marrado por mac não quero que ninguém que esteja cadastrado pega IP automaticamente.
    Pois bem esta solução funciona muito bem em servidor debian.
    Então fui fazer a mesma forma no pfsense.
    O problema que quando eu defino o mac e o ip do mesmo e não defino o range ele reclama informando que o tenho que defenir o range.
    Se eu definir o range as maquinas que fixo o ip com o mac não poderá estar no range que defini pois ele informa isso.
    Agora se eu não quero que ninguem que esteja cadastrado o MAC no servidor DHCP não consiga pegar IP por isso não posso definir o range.
    Alguém já conseguiu fazer este tipo de configuração?
    Agradeço.



  • @gilmarcabral:

    Se eu definir o range as maquinas que fixo o ip com o mac não poderá estar no range que defini pois ele informa isso.

    A interface de configuração do DHCP no pfsense critica isso?

    ips reservados dentro da faixa?



  • Olá,

    Realmente o Servidor DHCP do PFSense pede para que seja definido um Range. Nesse caso, pegue 1 IP da sua rede e use como inicial e final, depois marque a opção "Deny unknown clients", então aqueles que não estiverem com o MAC cadastrado não recebem IP.



  • Boa tarde.
    LFCavalcanti foi isso mesmo que acabei testando e acabou funcionando.
    Pelo que pesquisei isso não é algo relacionado ao pfsense e sim ao servidor isc-dhcp-server.
    Pelas pesquisas as novas versões de linux que utiliza o isc-dhcp-server e obrigatório utilizar o range.
    Achei estranho a obrigatoriedade.



  • @marcelloc:

    @gilmarcabral:

    Se eu definir o range as maquinas que fixo o ip com o mac não poderá estar no range que defini pois ele informa isso.

    A interface de configuração do DHCP no pfsense critica isso?

    ips reservados dentro da faixa?

    Isso mesmo Marcello: Se você tentar associar um IP da Range pelo MAC o pfSense não aceita, anunciando que a Reserva precisa estar fora da Range automática. Essa é a mensagem:

    The following input errors were detected:
        The IP address must not be within the DHCP range for this interface



  • @johnnybe:

    Isso mesmo Marcello

    puuuxa… parece mais uma restrição da gui do que limitação do daemon.

    Passível até de questionamento no fórum internacional.

    De qualquer modo, o ipguard pode ajudar a fechar o resto. ;)



  • Bom dia.
    Pode ate ser alguma coisa na GUI pois que é estranho você ter que setar um range mesmo marrando por mac isso é.



  • @marcelloc:

    Passível até de questionamento no fórum internacional.

    Já existe uma discussão sobre isso aqui: http://forum.pfsense.org/index.php/topic,57808.0.html

    Abraços!
    Jack



  • Aquilo que o jimp falou eu já sabia.
    http://forum.pfsense.org/index.php/topic,57808.msg309367.html#msg309367

    São limitações inevitáveis. Fazer o que…



  • Galera boa tarde.
    Bom o Rodolfo me informou uma solução que aparentemente resolveria o problema.
    E o seguinte.
    No servidor dhcp eu habilitar o uso de Static ARP e marrar por MAC.
    Pois então eu fiz e funcionou porem tem um detalhe que não sei como resolver.
    Cadastro todos MAC e IP e em seguinte habilito o Static ARP assim quem não tiver cadastrado mesmo que colocar IP manual na maquina o usuário não consegue entrar na lan.
    O problema que esta ocorrendo se eu reiniciar o Servidor Pfsense ou a tabela ARP expirar simplesmente as maquinas que estão cadastradas no dhcp server não consegue mais pegar IP e nem acessar a rede.
    Verifiquei que quando Habilito o Static ARP ele tem a função de não deixar outras entradas na tabela ARP mas como reiniciei o servidor a tabela ARP ficou em branco e o pfsense não consegue pegar estes mac autorizados registra-los.
    Pensei que poderia ser um BUG da versão 2.0.2 mas testei na 2.0.1 e ocorre o mesmo problema.
    Agradeço



  • Bom dia.
    Estou tentando adicionar um mac com seu ip na tabela ARP porem não estou tento sucesso.
    Conforme relatado acima estou arrumar uma maneira de fazer a opção do servidor dhcp STATIC ARP ter onde consultar a tabela ARP.
    arp -s 10.9.9.59 00:1b:24:fb:6c:d7
    cannot intuit interface index and type for 10.9.9.59

    Também tentei da forma que o help sugere mas apresenta a mesma mensagem:
    arp -s 10.9.9.59 00:1b:24:fb:6c:d7 temp pub
    cannot intuit interface index and type for 10.9.9.59

    Alguém sabe o que pode como resolver.
    Agradeço



  • boa tarde.
    Estavo informando o IP errado, estava informando o ip do proprio GW.
    Mas agora informei o IP da estação com o MAC apresenta a mensagem abaixo.

    cannot intuit interface index and type for 10.9.9.59



  • Galera ralando muito e pelos meus testes descobri o problema de não aceitar adicionar entradas na tabela ARP no pfsense.
    Depois de descobrir que após o reboot do servidor o que e normal a tabela ARP ser limpada e em seguia o pfsense ou eu mesmo adicionar as entradas manualmente na tabela ARP não dar certo ocorrendo a seguinte mensagem cannot intuit interface index and type for.
    Fiz o teste indo na interface OPT5 (WIRELESS) cujo o endereço de rede é 10.9.9.5/24 e mandei salvar novamente a configuração em seguida rodei o comando arp -s 10.9.9.59 00:1b:24:fb:6c:d7 e listei a tabela ARP e foi adicionada com sucesso.
    Realizei outros testes sempre que reinicio o servidor ai como ele não aceita adicionar as entradas nem manualmente na tabela ARP vou la na interface OP5 (WIRELESS) clico em salve ai em seguida consigo adicionar as entrada na tabela ARP



  • Consegue verificar se a faixa de ip da rede wireless não esta sobreposta em outra interface?



  • O ambiente esta assim.
    Wan 177.xxx.xxx.xxx.xxx
    Lan 192.168.1.5/24
    Wirelles 10.9.9.5/24

    O dhcp esta configurado para atribuir IP somente para a lan da
    Rede wireless.
    Marcello irei fazer mais testes para tentar descobrir se pelo menos
    O dhcp esta passando os MAC e IPS para a tabela ARP.



  • nao entendi…

    o meu sistema é bem parecido, mas como tenho que definir um grupo faco o seguinte:

    Meu range de IPs é: 192.168.4.1/20
    Seria 192.168.4.1-192.168.15.255

    Simplesmente coloco o range do DHCP em 192.168.5.1-192.168.5.1 e pronto, é só eu nao utilizar esse IP, e como nao esta cadastrado nenhuma MAC para o IP ele nunca vai utilizar, já que tenho as seguintes opcoes ativadas:
    **_- Deny unknown clients

    • Enable Static ARP entries_**

    ve se te ajuda em alguma coisa



  • Boa noite.
    Estou fazendo da mesma forma que você mas não estou entendendo
    o motivo e quando habilitou a opção status ARP IP simplesmente quando
    reinicia o pfsense a tabela ARP e limpa e o  ARP não tá aceitando utilizar
    às entradas de MAC contidas no DHCP Server.



  • Galera fiz um outro teste hoje.
    Reiniciei o pfsense ai a tabela ARP foi limpa ate aqui normal mesmo ai as maquinas não consegue pegar IP.
    Então apliquei a configuração da interface bce2 e simplesmente 2 maquinas que tinha seu mac cadastrado no servidor dhcp pegaram ip normalmente a outra não pegou pois não estava cadastrada no dhcp o que esta correto.
    Olhei a tabela arp e realmente estava la as entradas das 2 maquinas menos a terceira.
    Então o Static ARP esta funcionando juntamente com o Deny unknown clients.
    Agora o motivo que sempre tenho que aplicar a configuração da interface de rede bce2 para que seja adicionado as entradas na tabela ARP esta sendo um mistério.
    Fiz um teste alternado a mascara de /24 para /8 e mesmo assim não obtive sucesso.
    Caso alguém tenha alguma sugestão agradeço



  • Galera descobri o motivo disso ocorrer.
    Eu tinha uma rota criada no pfsense adicionando a rede 10.9.9.0/24 com o gw 10.9.9.5 ai retirei a mesma e o problema parou de ocorrer.
    Agora irei testar se a retirada desta rota ira implicar em algum acesso.
    Agora sim tudo funcionando.


Locked