Virtual IP's didn't work after setting a openVPN with a VIP-address [SOLVED]



  • Hi,

    First a bit of warning, I use old version of pfSense and this might be a obsolete in newer editions.

    
    Version 	2.0.1-RELEASE (i386)
    built on Mon Dec 12 18:24:17 EST 2011
    FreeBSD 8.1-RELEASE-p6
    

    I have multi-LAN and Single-WAN setup with 5 static public ip's.

    Problem started after setting up OpenVPN, and this have never occurred before hand.

    My main LAN uses original "hardware" IP which is given during setup. This subnet had no problems at all.
    My other LAN-subnets used VIP's with MON(Manual Outbound NAT)-settings so each subnet can be identified from used public ip if necessary. <– These failed.

    Troubleshooting:

    • Pinged from troublesome pc
      – GW was ok
      -- Other accessible subnets were also ok
      -- Nothing from outside could be pinged
      I've checked firewall settings and everything was as set, no changes there.
      I rebooted switches for other subnets, it didn't help
      Rebooted also modem if ARP-table or something else is failing, it didn't help
      During pinging to 8.8.8.8 I saved again this subnets outside VIP and voila it helped.
      After that I saved all the others again and problem went away.

    I think that it was quite weird place to have an error, but at least now i know where to look at next time if this happens.
    And I think that also rebooting a firewall could also solve this error.


  • Netgate Administrator

    @Metu69salemi:

    During pinging to 8.8.8.8 I saved again this subnets outside VIP and voila it helped.
    After that I saved all the others again and problem went away.

    So the running pfSense box forgot your manual outbound NAT settings? Or the VIP settings?

    Steve



  • VIP settings, after saving those again everything worked


Locked