Bge0: watchdog tiemout – resetting



  • Hi, it's my first post, so hello everyone :)

    I have a problem with Broadcom NIC interfaces. Two of them are built in MOBO, two are single PCI cards.
    Problem occur on every interface, but only on one interface. ( 1/4, 1/3 1/2)
    bge0 after rester work for ~5-10 sec, after that 5-7 min offline and again going UP for ~5-10 sec ….

    HP dl 360 G4 1U. firmware updated.
    2 x WAN
    1 x LAN

    what i did:
    I try latest pfsense 2.0.2 i386 and amd64.  - same situation bge0: watchdog timeout -- resetting
    http://doc.pfsense.org/index.php/Tuning_and_Troubleshooting_Network_Cards  - same situation bge0: watchdog timeout -- resetting

    any ideas, solutions ?



  • I suggest you try pfSense 2.1 snapshot builds because they are based on FreeBSD 8.3 which has much more up to date device drivers than FreeBSD 8.1 which is used in the pfSense 2.0.x series.



  • I think it is not good idea run "pfSense 2.1 snapshot builds" on production ? Am I right ?



  • If I recall correctly there are a number of posts in this forum reporting people using 2.1 snapshot builds in "production".

    If a 2.1 snapshot build stops your NICs going offline for minutes and otherwise does what you need why wouldn't you use it?



  • Today I'll try it, but first i try dual intel cards on 2.0.2. Will report later….



  • Ok, got some resoults.

    On pfsense 2.0.2 i386

    with 2x MOBO interfaces on and 2x dual intel interfaces system is stable no more bge: watchdog ….
    so it seems that two PCI cards conflict with MOBO interfaces.
    Now I try pfsense 2.1 amd64 beta 1 with 4 broadcom NICs.

    On 2.1 amd64 no change, still bge: watchdog ...


Locked