Automatic upgrade switched architecture?



  • I have a Dell R210 box running pfSense. It was a new 2.0.1 installation with 64 bit support (installed from pfSense-memstick-2.0.1-RELEASE-amd64.img). I did restore a configuration from a previous system running 2.0.1 32 bit, but I think that is the recommended 32 to 64 bit upgrade procedure. However once I updated to 2.0.2 a few weeks ago, via the WebUI, something strange happened - it updated fine and every pfSense feature worked ok afterwards. But when I tried to start emacs (which I had installed manually when I originally installed the Dell box) it could not load it - binary format incompatible. I found that quite strange until I realized that my 2.0.2 upgrade actually changed the pfSense installation to 32 bit?!

    This seems to be an error in the upgrade logic? or did I do something wrong?

    Thanks.


  • Rebel Alliance

    That happens because the Config have the Update URL, and when you restore the config.xml from the "32 bits install", it restores also the "32 bits Update URL", thats all….

    
     <firmware><alturl><enable><firmwareurl>http://updates.pfsense.org/_updaters/amd64</firmwareurl></enable></alturl></firmware> 
    
    


  • Ok - that certainly explains what happened - but when I read this:

    http://doc.pfsense.org/index.php/Upgrade_Guide#Changing_architecture_.2832_bit_to_64_bit_or_vice_versa.29_during_upgrade

    I find it a bit ambiguous. On one hand it says that changing architecture during upgrade is not supported, yet the recommended way to change architecture (reinstall, restore config.) that I used, is bound to fail per your explanation at the next upgrade, actually it will cause the system to do exactly what the documentation says is not supported. So now it seems even more like a defect, does it not?

    Thanks.



  • I had a similar issue happen during my upgrade.

    http://forum.pfsense.org/index.php/topic,57024.0.html

    I didn't know what the root cause was, but I suspect it was the same thing that happened to you.


Locked