Squidguard empty Target Rules



  • Hi, I have a problem with SquidGuard.
    I've installe Snort,Squid and Squidguard in this order on a 2.0.2 pfSense gitsynced to solve CaptivePortal problems.

    The problem is in proxy filter configuration:
    I've downloaded correctly the blacklist but when I click on Target Rules List, is empty!

    What could be the problem? I've also tried different blacklist but without success..

    Many thanks





  • Hi,

    on the second sceenshot you only can see your own created categories.
    If you download a blacklist from lets say www.shallalist.de then you will not see this in the GUI on second screenshot.

    When you download the blacklist squidguard will start to build the database. You will see that in the "Blacklist" GUI tab. Did this happen ?



  • Did you upgrade to a newer snapshot?

    I notice whenever I upgrade to a new snapshot my Shalla's blacklist disappears and I have to re-download.

    I also found the old tutorial here on setting up Squidguard on PfSense confusing.

    I used the one at SmallNetBuilder and that one worked for me,



  • Sorry, I didn't know that second screenshot was only my own categories.
    However blacklist was downloaded correctly (as you can see in the attached screenshot) but I can't see anything in Target Rules.
    If I try to re-download the same Shalla blacklist (or another like MESD) the behaviour is the same.
    Also rebooting box doesn't help.

    The strange thing is that Squidguard works correctly, in fact if I put a website in my custom category it is blocked by the proxy.




  • Need Enable blacklist.



  • @dvserg:

    Need Enable blacklist.

    Sorry I didn't see that flag, now it works ;D  ;D



  • @Gabri.91:

    @dvserg:

    Need Enable blacklist.

    Sorry I didn't see that flag, now it works ;D  ;D

    General Settings tab.


Locked