Acesso web através de várias WANs



  • Boas pessoal,

    Deixei esta questão no fórum geral mas talvez seja mais fácil explicar-me por esta via. ;-)

    Tenho um pfSense com as seguintes interfaces:

    le0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=8 <vlan_mtu>ether 00:50:7f:38:1e:7a
    	inet6 fe80::250:7fff:fe38:1e7a%le0 prefixlen 64 scopeid 0x1
    	inet x.x.x.x netmask 0xfffffff8 broadcast x.x.x.x
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect
    	status: active
    le1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=8 <vlan_mtu>ether 00:0c:29:b3:01:1f
    	inet 10.160.8.254 netmask 0xffffff80 broadcast 10.160.8.255
    	inet6 fe80::20c:29ff:feb3:11f%le1 prefixlen 64 scopeid 0x2
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect
    	status: active
    le2: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=8 <vlan_mtu>ether 00:0c:29:b3:01:29
    	inet6 fe80::20c:29ff:feb3:129%le2 prefixlen 64 scopeid 0x3
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect
    	status: active
    le3: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=8 <vlan_mtu>ether 00:0c:29:b3:01:33
    	inet 192.168.5.252 netmask 0xffffff00 broadcast 192.168.5.255
    	inet6 fe80::20c:29ff:feb3:133%le3 prefixlen 64 scopeid 0x4
    	nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect
    	status: active
    
    pppoe0: flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>metric 0 mtu 1492
    	inet6 fe80::250:7fff:fe38:1e7a%pppoe0 prefixlen 64 scopeid 0xa
    	inet x.x.x.x --> x.x.x.x netmask 0xffffffff
    	nd6 options=3 <performnud,accept_rtadv></performnud,accept_rtadv></up,pointopoint,running,noarp,simplex,multicast></performnud,accept_rtadv></vlan_mtu></up,broadcast,running,simplex,multicast></performnud,accept_rtadv></vlan_mtu></up,broadcast,running,simplex,multicast></performnud,accept_rtadv></vlan_mtu></up,broadcast,running,simplex,multicast></performnud,accept_rtadv></vlan_mtu></up,broadcast,running,simplex,multicast> 
    

    Acontece que apenas numa das WANs consigo ter acesso à interface Web do pfSense.

    Existe forma de aceder através de ambas?

    Obrigado pelas dicas!

    Abraço,

    Bruno Martins



  • @skorzen:

    Existe forma de aceder através de ambas?

    Sim…

    Para tanto, vá em "Firewall->Rules->Interface" e crie uma regra aceitando conexões de "qualquer origem" com destino à porta TCP/443.

    Nota: Procure acessar a WebGUI do pfSense sempre através de uma VPN (é muito mais seguro).

    Abraços!
    Jack



  • Olá JackL,

    @JackL:

    Para tanto, vá em "Firewall->Rules->Interface" e crie uma regra aceitando conexões de "qualquer origem" com destino à porta TCP/443.

    Eu tenho essa regra em ambas as interfaces, a questão é que só funciona na WAN1.
    A única diferença entre as duas interfaces é que a WAN1 está configurada por DHCP (IP fixo do operador) e a outra por PPPOE. Isto tem alguma influência?

    @JackL:

    Nota: Procure acessar a WebGUI do pfSense sempre através de uma VPN (é muito mais seguro).

    Abraços!
    Jack

    Eu tenho consciência disso. ;-) Obrigado pelo alerta.

    Cumprimentos,

    Bruno Martins



  • @skorzen:

    A única diferença entre as duas interfaces é que a WAN1 está configurada por DHCP (IP fixo do operador) e a outra por PPPOE. Isto tem alguma influência?

    Não.

    O melhor é ir na console/ssh e monitorar o acesso via tcpdump.


Log in to reply