HAProxy with NPN support to handle SPDY connections


  • I'm wondering if it is a hard task for the package maintainer to implement npn support into the current haproxy package to handle SPDY connection on web cluster.

    a nice detailed description to handle SPDY with HAProxy you will find here: http://go.ispire.me/spdyhaproxy

    What do you think?


  • Hey Jules,

    Im currently changing the haproxy-devel package for pfSense 2.1 based on HAproxy1.5dev17. And thought this could be a nice addition..

    But have hit a bit of a issue when trying to support/configure it haproxy tells me: "library does not support TLS NPN extension"

    Probably due to the 'old' OpenSSL version.. compiled into HAproxy.
    haproxy -vv tells me:
    Built with OpenSSL version : OpenSSL 0.9.8q 2 Dec 2010

    Basically the configuration could probably be done with the use of the advanced options.. But figuring out how to compile haproxy against OpenSSL1.0.0d or newer im not sure yet how to procede/change the package.xml build description to allow for this..

    If someone is willing to help out with this, no objections from me :). And ill happily add the ssl_npn ACL option into the php files.