Interface unable to connect to HTTPS websites.



  • Hello All,
    I am having some difficulty connecting to HTTPS from one of the PFSense interfaces. The firewall rule is interface [“PubWireless” Port-* Destination-* Port-* Gateway-* ] the only other ruls are blocks to the other interfaces. I am using transparent proxy and I thought that just forced port 80 traffic to that. A packet capture has almost nothing.
    This is a full trace on port 443
    08:42:21.345389 IP 192.168.20.53.65107 > 17.158.52.35.443: tcp 0
    08:42:21.348333 IP 192.168.20.53.65106 > 17.158.52.69.443: tcp 0
    08:42:21.348531 IP 192.168.20.53.65109 > 17.158.52.68.443: tcp 0
    08:42:21.348984 IP 192.168.20.53.65105 > 17.158.52.35.443: tcp 0
    08:42:25.859719 IP 192.168.20.53.65110 > 17.158.52.69.443: tcp 0
    08:42:25.859757 IP 192.168.20.53.65109 > 17.158.52.68.443: tcp 0
    08:42:25.859958 IP 192.168.20.53.65105 > 17.158.52.35.443: tcp 0
    08:42:34.380454 IP 192.168.20.53.65110 > 17.158.52.69.443: tcp 0
    08:42:34.380491 IP 192.168.20.53.65109 > 17.158.52.68.443: tcp 0
    08:42:34.380854 IP 192.168.20.53.65105 > 17.158.52.35.443: tcp 0
    08:47:07.244277 IP 192.168.20.53.65112 > 207.46.101.8.443: tcp 0
    08:47:08.289148 IP 192.168.20.53.65112 > 207.46.101.8.443: tcp 0
    08:47:09.324831 IP 192.168.20.53.65112 > 207.46.101.8.443: tcp 0
    08:47:10.358128 IP 192.168.20.53.65112 > 207.46.101.8.443: tcp 0
    08:47:11.390889 IP 192.168.20.53.65112 > 207.46.101.8.443: tcp 0
    08:47:12.431187 IP 192.168.20.53.65112 > 207.46.101.8.443: tcp 0

    I am attaching the Proxy Config and Filter Config. I have attempted to disable and even uninstall Squid and no change. The WorkStations interface has no problem getting to HTTPS. There must be something simple I am missing.

    Thank you in advance.

    Rich
    [Proxy Conf.txt](/public/imported_attachments/1/Proxy Conf.txt)



  • Did you tried to disable automatic redirect rule and/or change GUI HTTPS port number ?



  • Can you point me to a document that will assist me in making the change? Searched on line can’t fine.. I must be a newbe  ???



  • @fixyourdns:

    Can you point me to a document that will assist me in making the change? Searched on line can’t fine.. I must be a newbe  ???

    change these options on system -> advanced menu



  • Thank you sir….


Locked