Realtek 8169 instável em gigabit



  • re0: <realtek 10="" 8101e="" 8102e="" 8102el="" 8103e="" pcie="" 100basetx="">port 0xd800-0xd8ff mem 0xfdfff000-0xfdffffff,0xfdfe0000-0xfdfeffff irq 18 at device 0.0 on pci2
    re1: <realtek 8169="" 8169s="" 8169sb(l)="" 8110s="" 8110sb(l)="" gigabit="" ethernet="">port 0xe800-0xe8ff mem 0xfebffc00-0xfebffcff irq 16 at device 4.0 on pci3

    Estou percebendo uma certa instabilidade com placas realtek (re) em gigabit, alguém mais já passou por isso?

    Se deixo a placa em uma porta 100, fica 100%, se passo para a porta giga do switch, o acesso fica lento e em pouco tempo começa a perder pacote.

    Já testei outros cabos, categoria 5e e 6

    att,
    Marcello Coutinho</realtek></realtek>



  • Sim, tive o mesmo problema com esse modelo. Em Gigabit nada feito.



  • @johnnybe:

    Sim, tive o mesmo problema com esse modelo. Em Gigabit nada feito.

    Alguma opção/custo benefício além das placas intel?



  • Marcello. Eu tb tive o mesmo problema. Tinha Instalado duas D-link 530 Giga que usa esse chip realtek. Logo que subia o pfSense notava uma perca substancia de performance dele na rede. Ping muito alto, em torno de 3000ms, acesso a internet péssimo. Depois de muito sofrer com muitas alternativas, muitas mesmo, resolvi remover uma das placas, eram duas do mesmo modelo, e deixar uma Wan na interface On-Bord da Placa e uma D-Link na PCI. Pronto o problema sumiu e até agora não percebi nenhum anormalidade. Espero que esse problema seja resolvido para que outros colegas não percam a cabeça com ele como nós..kkkkk..

    Abraços

    ATT

    Breno Alencar



  • @marcelloc:

    @johnnybe:

    Sim, tive o mesmo problema com esse modelo. Em Gigabit nada feito.

    Alguma opção/custo benefício além das placas intel?

    Difícil essa. Já tive problemas com Atheros. Marvell seria outra opção. O problema maior é achar NIC com esses chipsets. O LFCavalcanti tem boas experiências com Atheros e Marvell, mas não sei dizer se Gigabit:
    http://forum.pfsense.org/index.php/topic,57945.msg309929.html#msg309929



  • @marcelloc:

    Alguma opção/custo benefício além das placas intel?

    Marcello,

    No que diz respeito à devices de "baixo custo", já usamos com sucesso (sem percepção de problemas) a TP-LINK TG-3468: http://www.tp-link.com/en/products/details/?model=TG-3468#over

    Ela carrega um chipset da família RealTek 8168/8111 B/C/CP/D/DP/E PCIe Gigabit Ethernet

    Abraços!
    Jack



  • Olá :D

    Atheros e Marvell em Gigabit tem funcionado bem. Não uso elas pra Links dedicados, só pra esclarecer.

    As realtek 8139D não funcionavam de jeito nenhum no PFSense 1.x.x, mas no 2.0.1 funciona muito bem.

    Sobre as 8186 e série… realmente em Gigabit elas tem perca, o problema acredito que seja no modulo, porque algumas revisões desse chip só funcionam com os Drivers presente do PFSense 2.1, ai tem aquele "port" postado aqui no fórum: http://forum.pfsense.org/index.php/topic,55563.0.html
    Só que este Port não funciona bem, estou enfrentando Crash em um servidor com a versão 2.0.2 e um chipset de rede dessa série, vou ter que instalar o 2.1 apra resolver.

    As melhores são Intel, 3Com e Cisco(vide Linksys), mas o custo tem papel determinante, então onde há margem para economia, o mercado exige.



  • @marcelloc:

    Se deixo a placa em uma porta 100, fica 100%, se passo para a porta giga do switch, o acesso fica lento e em pouco tempo começa a perder pacote.

    Marcellão,

    Acho que este "bug" está devidamente reportado aqui: http://www.freebsd.org/cgi/man.cgi?query=re&sektion=4&manpath=FreeBSD+8.1-RELEASE#end

    Abraços!
    Jack



  • @JackL:

    Acho que este "bug" está devidamente reportado aqui: http://www.freebsd.org/cgi/man.cgi?query=re&sektion=4&manpath=FreeBSD+8.1-RELEASE#end

    Bastante esclarecedor. Valeu Jack!



  • Parece que não é só para slots pci 64



  • @marcelloc:

    Parece que não é só para slots pci 64

    Pois é marcelloc…

    O problema é característico e documentado em relação a slots pci 64 (não tenho devices aqui pra simular o teste em slots pci 32). Mas de qualquer forma, o melhor é evitar o chipset no FreeBSD! ;)

    Abraços!
    Jack



  • Eu também tive problemas com a rtl8111, mesmo em vários lugares falando que era compatível com o pfsense 2.0.x eu não consegui fazer funcionar…fiz a instalação do 2.1 64b e tudo funcionou corretamente.....eu em particular agora em meus clientes estou migrando TODOS eles para pfsense e sempre falo que preciso de placas de rede homologadas e peço placas intel....e ta dando certo....
    Fica ai meus 0,01 de contribuição



  • Rodrigo, qualquer colaboração sempre é 100%  ;)

    JackL, obrigado pelo link do Bug.

    Enfrentei problemas com esse Chipset em uma placa mãe, chipt On-Board, pelo menos pelo que vi no Datasheet da mobo, o barramento era PCI-Express, creio então que o BUG se estende também a barramento interno(Onboard) e/ou Slot PCI-Express.



  • Enfrentei problemas também… D-Link DGE-528T que tem o chipset 8169... mas em modo 100Mbps em uma MB Intel DZ77SL-50K... o ping fica muito alto. O slot PCI que estou usando é 32bit.
    Fica minha colaboração..



  • @LFCavalcanti:

    tem aquele "port" postado aqui no fórum: http://forum.pfsense.org/index.php/topic,55563.0.html
    Só que este Port não funciona bem, estou enfrentando Crash em um servidor com a versão 2.0.2 e um chipset de rede dessa série, vou ter que instalar o 2.1 apra resolver.

    Como acontece esse Crash?
    Sempre uso a mesma placa com esse chipset, não tenho visto problemas, a não ser em dois clientes em que o firewall simplesmente para de responder ping, os gateways ficam offline, mas ainda não cheguei a conclusão se é a placa realmente pois quando isso ocorre, a memória sempre cai pra menos de 20MB embora tenha 8GB.


Log in to reply