Ftp Server inside firewall. Not working.



  • Hi
    I have a ftp server on my main computer and running pfsense 1.0-BETA1-TESTING-SNAPSHOT-2-2-06 on my router computer.

    i have put this in nat rules / port forward:
      WAN  TCP  21 (FTP)  192.168.0.210  21 (FTP)  ftp server   
       WAN  TCP  20  192.168.0.210  20  ftp server

    and this in rules / wan:
       TCP  *  *  192.168.0.210  21 (FTP)  *  NAT ftp server     
       TCP  *  *  192.168.0.210  20  *  NAT ftp server

    and my wan interface has ftp helper off. have tryed on too.
    and still no one can access my ftp server from outside..
    No traffic shaper is running..

    Has i configure something wrong here ? becuse it will not work at all.

    Regards Mike
    Sweden



  • You need to forward more than only these two ports. Your ftp server uses an additional range (which usually is configurable, so you have to look at the setting of the server which you need). Also some ftp-servers have to be configured to hand out the wan IP the clients see instead of their real IP. Check your serversettings and add the range you need to your forwardings.



  • the server is serv-u and there is only passive port range 10000-10002
    and that is forwarded too from lan to wan and from wan to lan. but still no one can connect.
    it dosent even respond to a connect message from any client.



  • Have found the problem.
    every user has to put ftp://ip adress:21/ to connect.
    this problem is solved. and finaly…


Locked