New packages: Zabbix-2 Agent and Zabbix-2 Proxy



  • Hello guys ..

    Zabbix-2 Agent and Zabbix-2 Proxy are available.

    Zabbix Version 2.0.4.

    Any problems, feedback. Thanks.

    Best Regards,



  • Hi dbaio,
    Many thanks for the Zabbix 2.0.4 packages. I've tested it and it works well.
    One thing is that I cannot see the status of the zabbix-agentd in the services information screen of pfSense.
    Are you adding this also to the package?
    Now to check the status you have always to do a ps auxw|grep zabbix on the console which is bad when you have that many firewalls active.

    Best regards,
    Peter



  • Hi…

    Thanks for your feedback.

    Check if you are with the last version.

    zabbix2-agent-2.0.4 pkg v0.5

    If yes, what pfSense version?

    Show me the return of "ps ax | grep zabbix_agentd"

    Regards.



  • zabbix_agentd shows fine for me in both the service page and the widget. The agent package works great, thank you very much dbaio.



  • @dbaio:

    Zabbix-2 Agent and Zabbix-2 Proxy are available.

    Hi Danilo

    I have Zabbix 2.0.5 server running at my own server.
    At client I installed your pkg.
    I can see this on log:
    53170:20130518:092357.804 Zabbix Proxy stopped. Zabbix 2.0.4 (revision 31984).
    33499:20130518:092407.825 Starting Zabbix Proxy (active) [Zenith_Proxy]. Zabbix 2.0.4 (revision 31984).
    33499:20130518:092407.825 **** Enabled features ****
    33499:20130518:092407.825 SNMP monitoring:      YES
    33499:20130518:092407.825 IPMI monitoring:        NO
    33499:20130518:092407.825 WEB monitoring:        YES
    33499:20130518:092407.825 ODBC:                  NO
    33499:20130518:092407.825 SSH2 support:          NO
    33499:20130518:092407.825 IPv6 support:          YES
    33499:20130518:092407.825 **************************
    33499:20130518:092407.827 [Z3005] query failed: [0] no such table: config [select alert_history,event_history,refresh_unsupported,discovery_groupid,snm
    ptrap_logging,severity_name_0,severity_name_1,severity_name_2,severity_name_3,severit

    (and lot of similar errors)

    and Zabbix server reports it can reach Zabbix proxy, but no data is available to show.
    I suspect I have problems with old installs of Zabbix-proxy (previous version to Zabbix server 1.8.x).
    Can you help me to diag this problem?

    EDIT1: OK… helping myself: I discovered the database is not generated!
    [2.0.3-RELEASE][admin@firewall.xxxx]/root(4): ls -la /var/db/zabbix2/proxy.db
    -rw-r–r--  1 zabbix  zabbix  0 May 18 08:58 /var/db/zabbix2/proxy.db

    searching for a how to recreate sqlite3 db for zabbix.
    EDIT2: ok... DB created following https://www.zabbix.com/documentation/2.0/manual/appendix/install/db_scripts

    shell> sqlite3 /var/lib/sqlite/zabbix.db < schema.sql
    (I found the schema.sql file on my server install)

    Now proxy appears to be working.
    So it's just matter of create it on install of pfsense pkg (if not exist)!



  • Service zabbix_agentd 2.0.4 don't starting.
    Problem in log file permissions?
    I correct in the
    /usr/pbi/zabbix2-agent-i386/etc/zabbix2/zabbix_agentd.conf
    parameter
    LogFile=/tmp/zabbix2_agentd.log
    After it, service started successfully.

    PfSense i386 2.1-RC0

    $ ls -la /var/log/zabbix2
    total 8
    drwxrw-r–  2 zabbix  zabbix   512 Jun 28 17:38 .
    drwxrw-r--  5 havp    havp    1024 Jun 28 17:38 ..

    Reboot - and all repeat...



  • Hello dbaio

    Thank you for your packages. I have installed the version 2.04 of the Zabbix agent and proxy on my pfSense FW. It is working fine so far.

    One major problem exist. I'm checking my hosts with the help of ICMP pings. This checks are working as expected if done from the Zabbix server directly. If they are done from the pfSense, it will never return "0" if the checked host is not accessible by a ping. The check returns always "1". As a result, it starts to flood my phone and mail with alerts who have a dependence on this ICMP ping… (net port, agent data etc.)

    I use the following item configuration:

    Type: Simple check
      Key: icmpping
      Type of information: Numeric (unsigned)
      Data type: Decimal

    Is there a way to debug this kind of error ? Anyone who get the same problem ?

    I have other proxies (Zabbix 1.8 on Gentoo) in another environments running fine with this type of checks.

    Sincerely
    Andreas



  • @dbaio:

    Hello guys ..

    Zabbix-2 Agent and Zabbix-2 Proxy are available.

    Zabbix Version 2.0.4.

    Any problems, feedback. Thanks.

    Hi!
    have problem with BETA zabbix2-agent-2.0.4 pkg v0.6_3 platform: 2.0 on PfSense 2.0.3-RELEASE (i386)
    in /var/log/zabbix_proxy.log i get :

     63130:20130904:153430.966 [Z3005] query failed: [0] no such table: hosts [select p.id,h.host,i.key_,p.clock,p.ns,p.timestamp,p.source,p.severity,p.value,p.logeventid,p.status from hosts h,items i,proxy_history p where h.hostid=i.hostid and i.itemid=p.itemid and p.id>0 order by p.id limit 1000]
     63130:20130904:153430.966 [Z3005] query failed: [0] no such table: ids [select nextid from ids where table_name='proxy_dhistory' and field_name='dhistory_lastid']
     63130:20130904:153430.966 [Z3005] query failed: [0] no such table: proxy_dhistory [select p.id,p.clock,p.druleid,p.dcheckid,p.type,p.ip,p.dns,p.port,p.key_,p.value,p.status from proxy_dhistory p where p.id>0 order by p.id limit 1000]
     63130:20130904:153430.966 [Z3005] query failed: [0] no such table: ids [select nextid from ids where table_name='proxy_autoreg_host' and field_name='autoreg_host_lastid']
     63130:20130904:153430.966 [Z3005] query failed: [0] no such table: proxy_autoreg_host [select p.id,p.clock,p.host,p.listen_ip,p.listen_dns,p.listen_port from proxy_autoreg_host p where p.id>0 order by p.id limit 1000]
    
    

    I'm create base from zabbix source, but log say -

    
    590:20130904:160517.520 cannot send list of active checks to []: host [1] not found
       590:20130904:160537.068 cannot send list of active checks to []: host [2] not found
      1357:20130904:160625.582 cannot send list of active checks to []: host [3] not found
      1357:20130904:160632.567 cannot send list of active checks to []: host [1] not found
      1357:20130904:160717.926 cannot send list of active checks to []: host [2] not found
      1357:20130904:160737.080 cannot send list of active checks to []: host [2] not found
      1357:20130904:160825.585 cannot send list of active checks to []: host [] not found
      1357:20130904:160832.568 cannot send list of active checks to []: host [] not found
    
    


  • Hi.

    There is a new version of agent and proxy packages.

    I think this problem was on the uninstall process.

    Any problems, let me know.



  • I also want to pipe in and say Thank You!
    I also have it in a working environment.
    It works perfectly.
    Now if I can only get it to work on FreeNAS…....... :-\


Log in to reply