27th jan snap error



  • im getting a lot of these in system log on the nanobsd on alix

    kernel: altq: packet for vr0 does not have pkthdr



  • also a few php errors saying running out of swap space, first time i have got this, config wise nothing changed and the 21st jan snap i restored to right now works fine


  • Rebel Alliance Developer Netgate

    The swap error is from filterdns.

    New snap is uploading right now that should fix that.

    The other may be related.



  • i reverted to 21st jan snap and im still seeing this, any idea what else could be causing it

    kernel: altq: packet for vr0 does not have pkthdr



  • it seems its happening due to wireless devices, not due to wired lan clients



  • Can you show output of ifconfig and arp -a



  • could this be the cause, setting MTU for wifi, lan and wan to 1492

    wifi is bridged to lan
    wan is pppoe which already gets 1492 but i also set 1492



  • after removing 1492 to all to blank and rebooting im no longer getting that error



  • after clearing the mtu boxes to blank, here is ifconfig

    vr0: flags=88943 <up,broadcast,running,promisc,simplex,multicast,staticarp>metri
    c 0 mtu 1500
            options=82808 <vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:0d:b9:xx:xx:xx
            inet 192.168.0.1 netmask 0xffffff00 broadcast 192.168.0.255
            inet6 fe80::20d:b9ff:fe13:4784%vr0 prefixlen 64 scopeid 0x1
            nd6 options=1 <performnud>media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active
    vr1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            options=82808 <vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:0d:b9:xx:xx:xx
            inet6 fe80::20d:b9ff:fe13:4785%vr1 prefixlen 64 scopeid 0x2
            nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect (100baseTX <full-duplex>)
            status: active
    vr2: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 1500
            options=8280b <rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate>ether 00:0d:b9:xx:xx:xx
            media: Ethernet autoselect
    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 00:80:48:xx:xx:xx
            media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
            status: running
    enc0: flags=0<> metric 0 mtu 1536
    pflog0: flags=100 <promisc>metric 0 mtu 33200
    pfsync0: flags=0<> metric 0 mtu 1460
            syncpeer: 224.0.0.240 maxupd: 128 syncok: 1
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
            options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000
            inet6 ::1 prefixlen 128
            inet6 fe80::1%lo0 prefixlen 64 scopeid 0xa
            nd6 options=3 <performnud,accept_rtadv>pppoe0: flags=88d1 <up,pointopoint,running,noarp,simplex,multicast>metric 0 mtu
    1492
            inet6 fe80::20d:b9ff:fe13:4784%pppoe0 prefixlen 64 scopeid 0xb
            inet 176.205.240.8 --> 195.229.252.27 netmask 0xffffffff
            nd6 options=3 <performnud,accept_rtadv>ath0_wlan0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0
    mtu 1500
            ether 00:80:48:xx:xx:xx
            inet6 fe80::280:48ff:fe60:7b07%ath0_wlan0 prefixlen 64 scopeid 0xc
            nd6 options=3 <performnud,accept_rtadv>media: IEEE 802.11 Wireless Ethernet autoselect mode 11g <hostap>
            status: running
            ssid "8mbps Blazing" channel 4 (2427 MHz 11g) bssid 00:80:48:60:7b:07
            regdomain NONE country AE ecm authmode WPA privacy MIXED deftxkey 2
            AES-CCM 2:128-bit txpower 30 scanvalid 60 pureg protmode OFF burst
            dtimperiod 1 -dfs
    bridge0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
            ether 02:5e:bf:xx:xx:xx
            id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
            maxage 20 holdcnt 6 proto rstp maxaddr 100 timeout 1200
            root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
            member: ath0_wlan0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 12 priority 128 path cost 370370
            member: vr0 flags=143 <learning,discover,autoedge,autoptp>ifmaxaddr 0 port 1 priority 128 path cost 55
    ovpnc1: flags=8051 <up,pointopoint,running,multicast>metric 0 mtu 1500
            options=80000 <linkstate>inet6 fe80::20d:b9ff:fe13:4784%ovpnc1 prefixlen 64 scopeid 0xe
            inet 10.15.2.30 --> 10.15.2.29 netmask 0xffffffff
            nd6 options=3 <performnud,accept_rtadv>Opened by PID 5947</performnud,accept_rtadv></linkstate></up,pointopoint,running,multicast></learning,discover,autoedge,autoptp></learning,discover,autoedge,autoptp></up,broadcast,running,simplex,multicast></hostap></performnud,accept_rtadv></up,broadcast,running,promisc,simplex,multicast></performnud,accept_rtadv></up,pointopoint,running,noarp,simplex,multicast></performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></promisc></hostap></up,broadcast,running,simplex,multicast></rxcsum,txcsum,vlan_mtu,wol_ucast,wol_magic,linkstate></broadcast,simplex,multicast></full-duplex></performnud,accept_rtadv></vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,simplex,multicast></full-duplex></performnud></vlan_mtu,wol_ucast,wol_magic,linkstate></up,broadcast,running,promisc,simplex,multicast,staticarp>
    


  • So you say its fixed now?



  • actually the issue is if u set the MTU for wifi to 1492 then the issue comes, the rest such as wan and lan if set to MTU of 1492 doesn't cause this to happen



  • @ermal:

    So you say its fixed now?

    to answer this, actually i see this as a bug as lan and wan set to 1492 works fine but setting wifi to 1492 causes this and it shouldnt be like that as lan to wifi bridged has a mtu of 1492 so to avoid fragmentation i set wifi to 1492 but then the errors. the reason im not going with adapter defaults is because when i do that i find web surfing etc slow down a little bit and setting 1492 improves my web browsing speed so i would like to have that set for all itnerfaces to improve speed as well as avoid fragmentation, meanwhile im trying out the 28th jan snap



  • tried the 28th jan snap and errors started again

    kernel: altq: packet for vr0 does not have pkthdr

    lan, wan only set to 1492 MTU, wifi on adapter defaults

    same settings for 21st jan snap dont give this error, they only start when wifi is also set to 1492 mtu



  • more errors on 28th jan snap

    Jan 29 09:31:14 hostapd: ath0_wlan0: IEEE 802.11 Fetching hardware channel/rate support not supported.
    Jan 29 10:48:07 hostapd: ath0_wlan0: IEEE 802.11 Fetching hardware channel/rate support not supported.
    Jan 29 10:51:54 hostapd: ath0_wlan0: IEEE 802.11 Fetching hardware channel/rate support not supported.



  • further analysis shows that the packet error, its the wifi to lan bridge and only happens when wireless devices tried to send data to wired lan computers, such as a file copy, file copy from wired computer to wireless works fine without errors



  • found it, setting lan interface to 1492 and wifi to blank causes the above issues i mentioned, removing the 1492 from lan to blank solves it


Log in to reply