SARG Reports can not be displayed



  • Hey everyone

    I have a pfsense with Dansguardian and Squid Proxy running.
    I have installed the SARG Package and configured a schedule.

    When I do a force update, it generates the reports in /usr/local/sarg_reports

    I can see that it creates an index.hml.gz and other files.

    However, if I go to the sarg package options and click on the "view report" tab, I get the message:

    Error: Could not find report index file.Check and save sarg settings and try to force sarg schedule.

    If I run Sarg in the console I get this:

    SARG: Records in file: 236, reading: 100.00%
    SARG: Successful report generated on /usr/local/sarg-reports/2013/01/30

    So i know the reports are generated, but still it can not be displayed.

    What could be the problem?

    Thanks for your time.



  • what options did you selected on sarg configuration?



  • I have the same problem, reports are generated on sarg-reports folder(/usr/local/sarg-reports), but the 'View Report' show as:
        "Error: Could not find report index file.
        Check and save sarg settings and try to force sarg schedule."

    My sarg options are:
      graphics
      convert ip to dns
      remove temp files
      generate main index.html
      generate index tree
      overwrite report
      use comma
      show full url
      show downloaded volume

    Reports are:
      topusers
      users_sites
      downloads

    I am using sarg 2.3.2 pkg 0.6.1, and pfsense 2.0.3-prerelease(amd64)



  • He, i attached my prob to another Topic, this seem to fit too.
    Maybe u can merge!?
    Heres Link:

    http://forum.pfsense.org/index.php/topic,59349.0.html

    Thx very much…



  • I'm having issues with sarg reports too. Also my realtime view stopped working since i updated to the latest 2.1 beta yesterday. I was on 2.0.2 before and at least the realtime view was working. but now with 2.1 beta i can get havp + squid working, so I think there's some tweaking for the realtime view to work again with taht new configuration, not sure.


Log in to reply