Ethernet Loop problem with WAN + Bridge + Switch



  • Hello,

    My config : Pfsense 1.2 Rc1
    1 Linksys Switch SRW2016
    Pfsense box : 4 Network cards (2 em:intel and 2 bce: dell)

    WAN (em0): IP adress : 213.2x7.xxx.x30/26
    Gateway : 213.2x7.xxx.x29

    OPT1 : Bridge with WAN and enable

    I also have Lan & DMZ with (NAT 1:1), it's work very well.

    Switch configuration (only details for Server 1):
    Port1: <-Internet Uplink->Routeur Colocation
    Port2: <-WAN<-Pfsense Box (em0)
    Port3: <-Bridge OPT1<-Pfsense Box (bce1)
    Port4: <-Server 1 (Ip adresses set : 213.2x7.xxx.x31 to 213.2x7.xxx.x64, netmask :255.255.255.192)

    My problem : for all traffic from Server 1 to Internet with a traffic > 64kb the connection is lost, if some try to download from Server 1 with FTP, the connection is lost when the downloaded file size reach 64Kb
    Same thing with VNC, the connection is lost after 10sec.
    I can reconnect, but it's seem there is a traffic size limit of 64kb.
    The problem doesn't exist for : Internet to Server 1, i can download without problem.

    There is a problem with interfaces, in pfsense  status are :
    WAN (em0)
    Bridge (bridge0) : blocking - check for ethernet loops

    OPT1 (bce1)
    Bridge (bridge0) : blocking - check for ethernet loops

    If I plug directly with a X cable Bridge OPT1 (bce1) to my Server 1, everything works fine.

    The problem only appear when Bridge OPT1 (bce1) is plugged on the switch (even if Server 1 is not plugged)

    It's a very weird problem, i try to create a VLAN1 for Port1,2 and VLAN 2 for Port3,4 on my switch but same problem.

    Thank you for your help.



  • The spanning tree protocol detected traffic looping between the 2 interfaces so it set the interfaces to blocking to prevent looping. Your switch is configured incorrectly or maybe your vlan settings for the pfSense (depending if you use tagged or untagged vlans).



  • Thanks for your reply, on the pfsense i can not create VLAN for my Broadcom card, only intel are listed on the VLAN section.
    On my switch i created a VLAN on port 3 & 4 that accepts only tagged frames.
    No VLAN are created on the pfsense box.
    I'm confused about how to set my VLAN on my switch, i follow the doc on

    http://www.linksys.com/servlet/Satellite?blobcol=urldata&blobheadername1=Content-Type&blobheadername2=Content-Disposition&blobheadervalue1=application%2Fpdf&blobheadervalue2=inline%3B+filename%3DSRW2016-SRW2024-v1.2_ug.pdf&blobkey=id&blobtable=MungoBlobs&blobwhere=1130838241939&ssbinary=true&lid=8983590529B04)

    What should i do ?

    I tried to create manually the VLAN on pfsense with the command:
    ifconfig vlan0 vlan 2 vlandev bce1

    but nothing happen.

    I have found:
    "Not all NICs support 802.1Q VLANs - look for VLAN_MTU and VLAN_HWTAGGING options for your NIC in ifconfig. man vlan provides further info. I found though that my adapter (bce0) was not listed in man vlan but it did support the necessary options and worked with VLAN tagging."



  • It's your switch then that is configured incorrectly as the interfaces see each others traffic.



  • Yes, i understand but do i need to create a VLAN on pfsense for the OPT1 interface too or just create my vlan on the switch is enaught ?


Log in to reply