[Q] Firewall: NAT: 1:1



  • Hi!
    I have AT&T DSL service with 5 static IP addresses.
    I so far got to set up all other things, but I have an issue with NAT.
    I need to make a computer available to outside for remote desktop.

    Thus, I wanted to add a NAT 1:1 at "Firewall: NAT: 1:1: Edit"

    Interface: WAN
    External subnet: 76.234.16.95 /32
    Internal subnet:  192.168.1.100

    Whenever I apply the changes, the computer loses Internet connection and can't get outside world.
    As soon as I delete the NAT rule, it gets back Internet.
    Did I miss something here?
    I really appreciate your help.



  • your current external subnet is /32 –> 1 IP
    if you have a /29 ip block change it to that, or if your 5 static IP's are spread within a bigger subnet create 4 Virtual IP's and create a 1:1 NAT for every VIP.



  • I'm not sure you meant the WAN subnet was /32. But if the WAN is using PPPoE, don't worry about the subnet on the interface- that's normal for PPPoE.
    If you were just trying to add a 1-1, make sure you have added the Virtual IP before trying to setup a 1-1. You could also use port-forwards instead of using 1-1 nats. Just add Virtual IPs for the additional addresses in your subnet and use them for externals when setting up port-forwards.



  • Maybe you don't even need VIPs. If you really just want to make one machine available to the public add a portforward with appropriate firewallrule (let it be autogenerated). I think you are overcomplicating things here.


Log in to reply