Grub boot problem



  • Hi I have installed pfsense 1.2 beta 2 but hang at grub boot loader. Can someone tell me how to fix this?

    Thank You



  • Can you provide some more information, like if you get any error messages? Are you using the latest build? How did you go about installing it?



  • Yes im using the latest pfsense 1.2 beta 2. After reboot the machine it hang on the grub loader. I remove pfsense 1.2 beta 2 and replace it with 1.2 beta 1 and running ok.



  • Make sure the bios is the latest and greatest.



  • I, too am having problems with Grub. I have a brand new install of pfsense from the 1.2 RC1. When I reboot I get Grub error 17. I went into the BIOS and tried tweaking all the settings for the SATA chipset (like others have suggested elsewhere to resolve this error). No matter what setting I choose I get the error.

    Initially I got a grub error 18. So when I re-installed pfsense I chose to make an additional 50Meg /boot partition (last in the list, as first in the list would not work with the installer, oddly the log said operation not permitted for the mount). This seemed to work (at least it got me from error 18 to error 17 … and that is one better ;-)

    Any thoughts? Is theresome easy way to replace grub with the freebsd bootloader from the shell running off the pfsense CD?

    Thanks in advance.

    FWIW: Amd 2.6GHz X2 on a Gigabyte GA-MA69VM-S2 motherboard using the latest (f4) BIOS.
    Drive is a Seagate ST303204N1A1AS-RK  320Gb.



  • So I tried installing from the Beta1 CD and it worked perfectly. It seems Grub does not like my BIOS for some reason. The freebsd bootloader works perfectly.

    Is there any option to NOT use grub with the newer release? Or could there be?

    I am going to try upgrading from the RC1 CD to see if that overwrites the bootloader or not.



  • I plan on adding a checkbox to toggle the behavior on the next RC.



  • @sullrich:

    I plan on adding a checkbox to toggle the behavior on the next RC.

    This is great news. Thanks.

    I ended up installing BETA1, and then using the upgrade firmware feature. This seems to have upgraded me to RC1, but kept my bootloader at the default freebsd loader.


Log in to reply