Kernel: Calcru error



  • In the system logs and also on the actual system screen I get the following error below.

    kernel: calcru: runtime went backwards from 964752 usec to 445142 usec for pid 15 (yarrow)

    This is on a production server thats been solid for about a year on version 1.0.1.  When I started getting them about a week ago so I decided to bump the pfsense version to 1.2 RC1 release.

    Any ideas what this means?

    Hardware of the machine is a P4-3Ghz 512megs DDR2 on a Supermicro board (way overkill)  80gig HD.  There are 4 Intel 1000 MT cards, 1 older intel 10/100, and 1 3Com 3C905

    Some stuff I found useful
    http://www.freebsd.org/doc/en_US.ISO8859-1/books/faq/troubleshoot.html#CALCRU-NEGATIVE



  • So this just started randomly with no changes to the hardware or software?

    When I've seen this previously it's always been fixed by either a BIOS upgrade or setting PNP OS to no in the BIOS. But all the times I've seen it, it did it immediately on install.

    First I'd check for any BIOS updates and check your BIOS settings.

    Might want to try changing the timecounter.hardware sysctl by running:

    sysctl kern.timecounter.hardware=i8254

    from a shell or the command page in the GUI. If that makes things worse, set it back to the default by running:

    sysctl kern.timecounter.hardware=TSC

    Note that won't survive a reboot, if it fixes the problem add it to a <shellcmd>tag in your config.</shellcmd>



  • Thanks I will give it a shot..

    But Yes..  NO Bios updates, no hardware changes it just happened.  I been itching to go to version 1.2 RC1 so I figured it would be a good time.  Only change but that was after the error.


Log in to reply