Atheros AR9280 "ath0: stuck beacon; resetting (bmiss count 4)" hangs later.



  • Let me first say the 2.1 SNAPSHOT upgrade process from 2.0.2 STABLE is awesome.

    Now, for my issue:
    I have two different Atheros AR9280 based Mini-PCIe cards, both of which are exhibiting the same behavior.  I've tried in 802.11a, 802.11b, and 802.11g modes, all using WPA2.

    One is a Sparklan WPEA-111N (half size), the other is a Ubiquiti SR-71e (full size).

    After a pfSense reboot, both cards are up and running for a period of time (minutes, usually), but I can connect without issue, quite solidly.  Note that 2.0.2 STABLE could do this for a couple of minutes, and the 2.1 SNAPSHOT I upgraded today (Feb 27, 2013) (details below) works for many minutes, but not an hour.  Over time, I see more and more  "ath0: stuck beacon; resetting (bmiss count 4)" and "ath1: stuck beacon; resetting (bmiss count 4)" and the radios go offline (i.e. no other WiFi sniffers I have can pick them up anymore - I have not yet pulled out the frequency scanner to see if they're transmitting malformed RF instead of good beacons).  With 2.0.2 I've also seen attempted hardware resets, but they clearly failed.  A reboot from WebGUI always corrects the issue for a few minutes.

    So far, I've used InSSIDer and Airodump-ng to track the beacons.  Note than when it dies, blind connections (as if the SSID was hidden) also no longer work.

    If anyone has a Mini-PCIe capable machine and needs hardware to help debug, I'm willing to purchase another one (just one, but whichever they like) and mail it to them.  If it gets fixed, they can keep it.  If it doesn't get fixed, I'd like it mailed back after they've exhausted their patience.  If there's a FreeBSD group I should go to instead, please let me know.

    I bought these two cards based on some indications of FreeBSD support, and because the Ubiquiti, at least, is one of the only apparently multi-OS supported Access Point capable genuinely high power Mini-PCIe cards available.  
    https://wiki.freebsd.org/dev/ath_hal(4)/HardwareSupport
    http://lists.freebsd.org/pipermail/freebsd-wireless/2011-May/000168.html

    Even after the radio is stuck, I see the interface as "up".  Disabling and re-enabling with Apply Changes after each does not make the radio work again.
    OPT3 interface (ath0)
    Status up
    MAC address x❌x❌x:x
    IPv4 address x.x.x.x  
    Subnet mask IPv4 255.255.255.0
    IPv6 Link Local x:❌x❌x  
    Media autoselect mode 11g <hostap>Channel 6
    SSID x
    In/out packets 664/643 (119 KB/347 KB)
    In/out packets (pass) 664/643 (119 KB/347 KB)
    In/out packets (block) 671/0 (50 KB/0 bytes)
    In/out errors 0/17
    Collisions 0

    ETA: Temperature is 55 degrees C.</hostap>



  • im gettting stuck beacon since 2-3 days now a lot, i have the below set till date which avoided this issue but with those set also im getting stuck beacon

    hw.ath.bstuck = 8
    hw.ath.longcal = 30
    


  • try setting those under system->advanced->system tunables



  • Thank you very much, xbipin.

    Do you have the time to help explain what each of those settings mean, or link to some reasonably accurate documentation on them?



  • frankly speaking im not the right guy for freebsd but those settings i had discovered a year or two back in a wireless thread and many were facing same issue and some1 reported those setting and solved the issue



  • bytheway do u use the Ubiquiti SR-71e on the alix or a normal PC coz i was looking for a high powered wifi card but was afraid alix might not give it enough power



  • I haven't had a chance to try the settings yet.

    Xbipin, right now, I have both cards in a Fit-PC3 Pro that was slightly modified by thefitpc.com for me; they added two more RP-SMA bulkheads so I can attach 4 antennas, two for each card.  My previous wireless router+OpenVPN was a netgate ALIX box using an Engenius EMP-8602plus-S (also a high power card), which works great with at least pfSense 2.0.1, but I wanted gigabit, more LAN ports, more CPU, much more RAM, and a hard drive (Snort, Squid, Squidguard in addition to OpenVPN).

    Remember that ALIX boards are Mini-PCI (like many professional WISP routers), while the Fit-PC3 are Mini-PCIe (i.e. PCI Express based, not PCI based).  The cards are NOT cross-compatible!

    For an Alix with pfSense 1.2.3 or 2.0.1, I can unreservedly recommend the Engenius EMP-8602 Plus-S, which is a 600mW dual band card, like the Ubiquiti SR71-e (I tend to work in the 5Ghz band, i.e. 802.11a, for a variety of reasons - lack of congestion being one).

    Basically, the Engenius EMP-8602 Plus-S is a 600mw half size Mini-PCI, while the Ubiquiti SR71-e is a full size Mini-PCIe.



  • thanks for the info, i was just checking out the fit pc3 pro, seems good, does the HDD go in the case as well and how well does it perform and what about heat dissipation?



  • I've got the Fit-PC3 Pro with the 4 Intel NIC + 4 USB FACE card (pfSense 2.0.2 sees those but not the Realtec onboard, 2.1 sees all five).

    On the bottom, in the middle there is a large aluminum plate held in by one screw that slots in securely; the hard drive is screwed directly into the aluminum plate, and the whole hard drive+plate drops down and then slides in to both close the plate and seat the SATA connectors, like many laptops but without the flimsy plastic.

    Heat dissipation is good… which means it gets fairly hot, uncomfortable to the touch on the top of the fins with extended high CPU.  A small fan (I sometimes use a small fan powered by the machine's own USB) cools it until it's quite cool, even at low power.



  • ill probably wait for the alix upgrade which should be out before mid 2013 with 4 realtek gigabit nics, 2-4gb ddr3 ram, amd 1ghz dual core processor, msata slot, sd slot with same form factor as current alix coz they dont heat up much plus no moving parts so its completely silent



  • I started a Hardware thread to ask about the new Alix - http://forum.pfsense.org/index.php/topic,59555.0.html - @xbipin or others, if you know more about upcoming Alix hardware, please post there, thanks.



  • xbipin, you are the entity!  I ran 32000 byte pings from a client to the pfSense box (WPEA-111N) for 23 hours without any hangs, with a total of 2.5GB of data transferred.

    At this point, I've got OpenVPN (Camellia-256-CBC) running over the Wifi, and the LAN link to a VM on the wifi host with a gigabit USB2 hardwired network card into one of the Intel ports, and have been running iPerf

    
    iperf -c <wifiopenvpn_ip>--tradeoff --len 8K -w 128K -P 1 -t 30 -i 5 -m</wifiopenvpn_ip> 
    

    repeatedly for at least 10 minutes, with speeds varying from ~10Mbits/sec to ~30Mbits/sec.  The Fit-PC3 Pro is averaging about 1% CPU per Mbit transfer on CAMELLIA-256-CBC with RSA-SHA512 authentication - I'm sure AES-128-CBC and SHA256 authentication would be lower, even without AES-NI.

    During the 23 hour ping test, I did see the occasisonal burst of "ath0: stuck beacon; resetting (bmiss count 8)", but they cleared up on their own, and it just kept responding even after the occassional timeout (again, on 32000 byte packets).

    Thank you very much for your help - if there are any references on precisely what those tuning values are, I'd appreciate it, as I'd like to know how to find the "best" values.



  • i guess its just some interval timing stuff coz stuck beacon usually happens in noisy environments and/or DMA timings, busy bus etc where the card thinks it cant transmit

    probably u should send me that card  :)



  • Status update:
    The System Tunables settings of

    
    hw.ath.bstuck = 8
    hw.ath.longcal = 30
    
    

    have corrected the pfSense wifi interface hangs.

    http://forums.freebsd.org/archive/index.php/t-14616.html indicates longcal 30 is a default.
    http://lists.freebsd.org/pipermail/freebsd-stable/2011-March/061772.html indicates that the AR9280's in particular were being worked on in the FreeBSD kernels.

    The Sparklan WPEA-111N  is delivering some very strange asymmetric rates that I need to track down further, but it did transfer 2.5GB of data on the iPerf test before the client app running on a PC stalled out - no fault of pfSense.

    The same iPerf test on the Ubiquiti SR-71e delivers an incredibly consistent 20Mbit/s in one direction and 22Mbit/s in the other direction, and did so for over 40GB of data transmitted each way.  Note that under the 20Mbit/s rate, with either Camellia or AES on the OpenVPN connection, the CPU usage was in the 27-40% range, averaging about 30%, and the temperature pfSense was reporting on the Dashboard was 62C with the little USB fan running, and up to 76C without, despite the ribbed case.

    The Sparklan is still seeing the odd "ath0: stuck beacon; resetting (bmiss count 8)", though the Ubiquiti is not; I'm going to pull out my Bullet 5M and try the spectrum analyzer mode; in particular watching it when, say, the microwave starts.

    All tests done on 802.11a, 5Ghz, with pfSense 2.1 snapshot "2.1-BETA1 (amd64) built on Wed Feb 27 16:09:04 EST 2013".



  • @Nadrek:

    Status update:
    The System Tunables settings of

    
    hw.ath.bstuck = 8
    hw.ath.longcal = 30
    
    

    Can someone please explain what these tunables do?  What does higher or lower numbers represent/do in both settings?  I've tried these settings and still get stuck beacon errors so I tried setting bstuck=12 - no more stuck beacon errors but wifi connectivity still drops out periodically.



  • did u find a fix for this?



  • i noticed enabling WME also causes stuck beacon to happen more often, since i disabled, i didnt get any


Log in to reply